VCF authenticated downloads configuration update instructions
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VCF authenticated downloads configuration update instructions

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Article ID: 390098

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Updated On: 04-08-2025

Products

VMware vCenter Server VMware Cloud Foundation VMware vSphere ESXi VMware SDDC Manager VMware vSAN

Issue/Introduction

Affected products are no longer able to download updates from internet facing VMware by Broadcom public repositories. This article describes the process to update affected products with provided details.

Environment

Async Patch Tool (AP Tool)
Offline Bundle Transfer Utility (OBTU)
SDDC Manager 4.5.x
SDDC Manager 5.x
Update Manager Download Service (UMDS)
VMware vCenter Server 7.x
VMware vCenter Server 8.x
VMware vSphere ESXi 7.x
VMware vSphere ESXi 8.x
vSAN File Services

Cause

Public facing repository URLs and authentication mechanisms are changing. Download URLs are no longer common but unique for each customer, therefore will require to be re-configured.

Resolution

  1. Download Token

    The common first step for ALL products is to obtain a Token from Broadcom Support Portal.

    Notes:

    • This assumes, you as the end user, has valid login credentials to Broadcom Support Portal and authorized to a Site with entitlements to VCF software.
    • Effective 3/31/25, only users with the Product Administrator role have the capability to create the token for their site.
    • Access and additional portal roles to the Broadcom Software Portal is typically managed by a designated User Administrator. The User Administrator can apply the Product Administrator role to the necessary individual(s) who will then have the ability to generate unique tokens to be used for software downloads for their site. 
    • A customer with multiple environment owners under one Site ID can use this new functionality to designate Product Administrators and manage who can generate unique tokens.
    • Please refer to the KB article Manage user permissions and Site ID access as a User Administrator for guidance on how User Administrator can grant Product Administrator role.
    • Please refer to the KB Article Request the Product Administrator role to manage Portfolio License Agreement (PLA) products on how customers can raise a request for Product Administrator role. 

      • Login to Broadcom Support Portal
      • Use the dropdown next to Username and select VMware Cloud Foundation.



      • In support portal click on “Generate Download Token
      • Pick the correct Site and click Generate

  2. Update the Download repository URLs for each Product / Component

    Notes:

    • The software depots address has changed to "dl.broadcom.com" for all the VCF Products or Components. Please ensure that the affected components can reach the dl.broadcom.com through your firewall. Once you've successfully reconfigured your depots, you may wish to remove the legacy depot addresses depot.vmware.com, hostupdate.vmware.com, and vapp-updates.vmware.com from your firewall as these addresses will be retired at a future date.
    • If available, scripted method is the preferred option to update the configurations.

      Depot Component Scripted Method Manual Method
      VCF Depot SDDC Manager KB389276 KB389871
      Offline Bundle Transfer Utility (OBTU) Not Available KB390119
      Async Patch Tool (AP Tool) Not Available KB390122
      vApp Update (vCenter) vCenter Server KB389276 KB390120
      Host Update (ESXi) vSphere Lifecycle Manager (vLCM) and
      VMware Update Manager (VUM)
      KB389276 KB390121
      Update Manager Download Service (UMDS) Not Available KB390123
      Auto Deploy / Image Builder Not Available KB391021
      vSAN File Services vSAN Not Available KB390237