Unable to patch the vCenter via VAMI as it fails to download the updates from Broadcom public repositories
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Article ID: 390120
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Updated On:
Products
VMware vCenter ServerVMware vCenter Server 7.0VMware vCenter Server 8.0
Issue/Introduction
Symptom:
vCenter Server patching via VAMI fails to download the updates from Broadcom public repositories.
VAMI Updates tab will show any of following error messages: The vCenter Server is not able to reach the specified URL. Ensure that the vCenter Server is connected to the internet, the specified URL is correct, and the latest version(s) is available on the VMware online repository. If the issue persists, please contact VMware Support.
Error seen on VAMI UI "Check the URL and try again."
Steps: Login to VC VAMI UI (https://vcenter_server_fqdn/IP:5480) > Update .
Authentication failure. Enter a valid user name and password, and try again.
Validation:
Error seen from vCenter "Configured repository is not accessible due to network connectivity or incorrect URL. Verify the repository settings."
Error seen from vCenter "Configured repository is not accessible due to network connectivity or incorrect URL."
Steps for vCenter 8.x: select vCenter > Updates > Prechecks > select target version "SELECT VERSION" .
Environment
VMware vCenter Server 7.x
VMware vCenter Server 8.x
Cause
Public facing repository URLs and authentication mechanisms are changing. Download URLs are no longer common but unique for each customer therefore will require to be re-configured.
Note: Replace <downloadToken> with the actual downloaded token id.
Update the New URL in Specified, and click Save
Releases should get listed from the new entitled URL
Notes:
The custom URL is not preserved post migration upgrade, FBBR restore and VCHA failover
If there is a proxy device configured between vCenter and the internet, ensure it is configured to allow communications to the new URL
Further patches automatically update this URL. For example, if 8.0.3.00400 is patched to 8.0.3.00500, the default URL will change to end in 8.0.3.00500.
When custom / specified URL is saved with token in VAMI. CLI patching will not pick this URL. We need to follow below steps to use the updated URL - set the current url from appliancesh
#update.set --currentURL https://dl.broadcom.com/<downloadToken>/PROD/COMP/VCENTER/vmw/8d167796-34d5-4899-be0a-6daade4005a3/8.0.3.00000.latest then install patch. #software-packages install --url
1. If we set Specified URL in VAMI UI, it is not reflecting in update.conf and when we run update.get it still points to vapp-updates Default URL. So if we continue to stage/install it goes via Default vapp-updates URL. So customer has to set the Specified URL using update.set from appliancesh as a workaround.
2. Another observation is that , if source is less tham 70U3 i.e 70U2/U1/GA then if above specified URL is given as in KB (https://dl.broadcom.com/<downloadToken>/PROD/COMP/VCENTER/vmw/8d167796-34d5-4899-be0a-6daade4005a3/7.0.3.02200) then it is patching to 7.0.3.02200 version itself and not patching to 7.0.3.02300 which is the TOT version for 70 So the workaround for 70x customers is to set the Specified URL manually using update.set in appliancesh.
On 80x VCSA:
Specified URL used:https://dl.broadcom.com/<downloadToken>/PROD/COMP/VCENTER/vmw/8d167796-34d5-4899-be0a-6daade4005a3/8.0.3.00400 If we set Specified URL in VAMI , it is not reflecting in update.conf but when we run update.get it is reflecting Specified URL correctly unlike 70x. Staging and Install is proceeding with Specified URL