VMware Aria Operations for Logs upgrade fails with the error failed to find server
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VMware Aria Operations for Logs upgrade fails with the error failed to find server

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Article ID: 420388

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • Triggering inventory sync for VMware Aria Operations for Logs in VMware Aria Suite Lifecycle with the error
    Error Code: LCMCOMMON80049
    Failed to find the product or its nodes in the provided vCenters. Make sure all the nodes are part of the vCenter's currently provided. If not add missing vCenter's details. Also make sure the credentials for all the provided vCenters are valid. Additionally, verify if the vCenter password saved in locker is consistent with the actual vCenter password. If it is not, update the password in locker and retry.
    Failed to find the product in the specified vCenter. vRealize Log Insight instance with hostname <AriaOpsforLogsFQDN> not found in given vCenter details. Make sure the DNS name field in the vCenter for the node is same as the node hostname and node is powered on in the vCenter Server. Make sure all the nodes are present in the vCenter Servers provided. Else, add the missing vCenter Servers. Ensure the credentials provided for the vCenter Servers are valid or skip the task using the 'Skip vCenter validation' option during retry
    
  • All VMware Aria Operations for Logs nodes are online when accessing https://<ARIA_OPERATIONS_FQDN>/admin documented so the following KB does not apply Upgrade Precheck of Aria Operations in Aria Lifecycle fails when validating nodes online status. 
  •  vCenter credentials are valid for Datacenter in VMware Aria Suite Lifecycle UI as per KB Inventory sync of Aria products fails with Error code: LCMCOMMON80049 at validating vCenter credentials 

  • Navigating to Lifecycle Operations → Environments →  Selecting the VMware Aria Operations for Logs environment card → Then selecting the affected node →  Expand the node details →  FQDN for the node shows as localhost in VMware Aria Suite Lifecycle UI

Environment

VMware Aria Suite Lifecycle 8.18.x

VMware Aria Operations for Logs 8.18.x

Cause

VMware Aria Operations for Logs node(s) has hostname set with incorrect value

Resolution

  1. Take Snapshot of all VMware Aria Operations for Logs nodes as per KB How to take a Snapshot of VMware Aria Operations for Logs 
  2. Follow the steps in KB The hostname is reverted to "localhost" after upgrading to Aria operations for logs 8.x to set the hostname with the correct value
  3. Trigger Inventory sync for the VMware Aria Operations for Logs environment. You can use the following documentation as a guide Inventory synchronization in VMware Aria Suite Lifecycle
  4. During the Inventory Sync you maybe prompted to enter in the vCenter Credentials again, please hit retry and fill in the correct credential details.  You can use the following as a guide Inventory sync of Aria products fails with Error code: LCMCOMMON80049 at validating vCenter credentials
  5. Try to upgrade VMware Aria Operations for Logs again through VMware Aria Suite Lifecycle .  The following is a guide to upgrading products through VMware Aria Suite Lifecycle Upgrade a VMware Aria Suite Product