Inventory sync of Aria products fails with Error code: LCMCOMMON80049 at validating vCenter credentials
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Inventory sync of Aria products fails with Error code: LCMCOMMON80049 at validating vCenter credentials

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Article ID: 345996

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • Inventory sync of Aria products fails with Error code: LCMCOMMON80049 at validating vCenter credentials.
  • Below is the screenshot from one of the Aria product(Aria Automation) with the error message:

    "Failed to find the product or its nodes in the provided vCenters. Make sure all the nodes are part of the vCenter's currently provided. If not add missing vCenter's details. Also make sure the credentials for all the provided vCenters are valid. Additionally, verify if the vCenter password saved in locker is consistent with the actual vCenter password. If it is not, update the password in locker and retry.
    Failed to find the product in the specified vCenter. vRealize Operations instance with hostname Aria_product_FQDN not found in given vCenter details. Make sure the DNS name field in the vCenter for the node is same as the node hostname and node is powered on in the vCenter Server. Make sure all the nodes are present in the vCenter Servers provided. Else, add the missing vCenter Servers. Ensure the credentials provided for the vCenter Servers are valid or skip the task using the 'Skip vCenter validation' option during retry"

  • Datacenter validation fails with below error : "Invalid details for VC data collection. Please enter correct hostname and password. Could not add vCenter with provided details. See the request details for more information"

Environment

Aria lifecycle manager 8.x
Aria Automation 8.x
Aria Operations 8.x (Including Cloud Proxy)
Aria Operations for logs 8.x

Identity Manager 3.3.x

Cause

This can happen if your vCenter validation on Aria Suite Lifecycle fails with an old username/password or username/password has been updated and Aria products still tries to authenticate with an old username/password.

OR

The vCenter managing the Aria product is not added to the Datacenter in Aria suite Lifecycle 

Resolution

Add the vCenter to the Datacenter for Aria Suite Lifecycle, follow the below steps:

Note: Ensure that you have the vCenter fully qualified domain name, user name, and password.

  1. On the left pane, click Datacenters.
  2. To add a vCenter, on the Datacenters page, click + Add for the vCenter.
  3. Enter the vCenterName and vCenter FQDN.
  4. Click Select Credentials for the vCenter.
    You can either search for an existing vCenter credentials or add new credentials using the + sign .
    Click the + sign on the right corner to assign a password for the selected vCenter credential.
    Enter the Password details and click Add.
  5. Enter the vCenterUser Name for the vCenter.
    You should have the required vCenter privileges.
  6. Select the vCenterType.
    Management: All VMware SDDC Suite products are managed by this vCenter type.
    Workload: All the payload or business related VMs are managed by this vCenter type.
    Consolidated Management and Workload: Is a vCenter type, where both VMware SDDC Suite products and payload VMs are managed together.

    The vCenter type selection is used only for classification; the setting has no associated product functionality.
  7. Click Validate and Save the changes.

Once the vCenter is added to the Datacenters page, retry the inventory sync and provide with the correct vCenter details:

Workaround for invalid credentials:

  • The workaround is to retry the inventory sync with updated password for vCenter validation:
  1. Validate the vCenter credentials from the LCM Datacenter with correct password from locker.
  2. Make sure validation succeeds and click save.
  3. Retry the inventory sync and provide with the correct vCenter details:

  1. Click Submit. 

NOTE: In the case of a manually added Aria Operations Cloud Proxy, if the Cloud Proxy is added in a separate datacenter, then the data center it has been deployed to needs to be added in Datacenters if it has not been added already.

Once it has been added and validated, the Inventory Sync task may still fail, as Lifecycle does not yet associate that vCenter with the Aria Operations environment. You will need to Retry the task and supply the credentials of the vCenter that the Cloud Proxy was deployed to so that it can be associated to the environment. If multiple proxies have been added, repeat for each hostname or IP that returns the error



Additional Information

Impact/Risks:

  • Inventory sync will of Aria product will fail.