"Upgrade Blocked" status when attempting to upgrade App Control agents
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Article ID: 286481
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Updated On:
Products
Carbon Black App Control (formerly Cb Protection)
Issue/Introduction
Agent shows as "Upgrade Blocked" within the Assets > Computers > "Upgrade Status" column.
Environment
App Control Agent: All Supported Versions
App Control Console: All Supported Versions
Cause
The Configlist Version (CL Version) on the endpoint is lower than the CL Version for Upgrade as shown at the top of the page in the Console > Assets > Computers.
Resolution
Verify the Agent is showing as Connected in Assets > Computers.
Navigate to Assets > Computers > Show Columns > add CL Version > Apply.
Verify the Agent's CL Version meets or exceeds "CL Version for Upgrade before attempting to upgrade again.
If necessary, navigate to https://ServerAddress/shepherd_config.php and change the Property MinConfigListVersionForUpgrade to match the Current CL Version.
When a new Agent Host Package installer is uploaded to the Server the current Configlist Version is written to the Shepherd Config MinConfigListVersionForUpgrade