Upgrade Status: Upgrades Disabled
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Upgrade Status: Upgrades Disabled

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Article ID: 292562

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Updated On:

Products

Carbon Black App Control (formerly Cb Protection)

Issue/Introduction

  • Agent shows "Upgrades Disabled" in the Upgrade Status column.
  • Inability to manually upgrade agents from Assets > Computers.
  • Inability to allow upgrades from the "Allow Upgrades" box in Policy Settings.

Environment

  • App Control Server: All Supported Versions
  • App Control Agents: All Supported Versions

Cause

Global "Automatic Agent Upgrades" (Server 8.9 or Earlier) or "Allow Agent Upgrades" (Server 8.10 and Higher) setting is disabled.

Resolution

1. Navigate to Rules > Policies
2. For each policy, uncheck the "Allow Upgrades" box and click Save.
3. Navigate to System Configuration > Advanced Options tab.
4. Under "Carbon Black App Control Agent", enable "Automatic Agent Upgrades" (Server 8.9 or Earlier) or "Allow Agent Upgrades" (Server 8.10 and Higher) and click Save.
  • Enabling the "Allow Upgrades" (Server 8.9 or Earlier) or "Automatically Upgrade Agents" (Server 8.10 and Higher) box in Policy Settings will now trigger an upgrade for every endpoint in that policy.
  • Upgrades can now be initiated from Assets > Computers, checking the box next to an endpoint and clicking the Actions button, then 'Upgrade Agent'.

Additional Information

To ensure that too large a number of endpoints aren't upgraded simultaneously, the "Allow Upgrades" (Server 8.9 or Earlier) or "Automatically Upgrade Agents" (Server 8.10 and Higher) option in Policy Settings should be used with caution.