App Control: Agent Will Not Update CL Version When Agent Upgrade Is Pending
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Article ID: 289169
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Updated On:
Products
Carbon Black App Control (formerly Cb Protection)
Issue/Introduction
Agent CL Version remains constant, despite the CL Version in the Console continuing to increase with changes.
Agent Upgrade is in an Upgrade Requested or Upgrade Scheduled state.
Environment
App Control Server: All Supported Versions
App Control Agent: All Supported Versions
Cause
Config List updates are sent by the same mechanism that sends Agent Upgrades. If an endpoint has a pending Agent Upgrade, it will stop getting CL Upgrades until the Agent Upgrade completes.
Resolution
The pending Agent Upgrade will need to be cancelled for the updated Conflig List to be sent to the Agent. This can be done either individually, Agent by Agent, or it can be done globally, for all Agents.
Individual Agent:
Login to the Console and go to Assets > Computers > relevant Computer.
From the menu on the right, choose the option: Remove Upgrade Request.
Globally (All Agents):
Login to the Console and go to the gear icon > System Configuration > Advanced Options > Edit.
Change: "Automatic Agent Upgrades" (Server 8.9 or Earlier) or "Allow Agent Upgrades" (Server 8.10 and Higher) from Enabled to Disabled. Save changes.
Go to: Assets > Computers and verify that Agents begin receiving the updated Config List.
Additional Information
Additional troubleshooting may be necessary prior to enabling Agent Upgrades if the Config List still is not being sent to the Agents.