Troubleshooting Console Unavailability
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Troubleshooting Console Unavailability

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Article ID: 286048

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Updated On:

Products

Carbon Black App Control (formerly Cb Protection)

Issue/Introduction

Error when launching App Control Console:

  • "The Carbon Black App Control console cannot connect to the database. Ensure that the database server is running. If the issue persists, contact Carbon Black technical support."
  • "The Cb Protection Console cannot connect to the database. Ensure that the database server is running. If the issue persists, contact Carbon Black technical support."
  • "Fatal Error: The Carbon Black App Control Console cannot connect to the database. Ensure that the database server is running. If the issue persists, contact Carbon Black support"
  • "Network error while trying to communicate with Carbon Black App Control Server"
  • "Error: Could not connect to host"
  • ERR_CONNECTION_RESET, ERR_ABORTED or similar error message

Environment

  • App Control Console: All Supported Versions
  • Microsoft Windows Server: All Supported Versions

Cause

  • Network connectivity to SQL server has been disrupted (Two Tier Environments)
  • SQL Server services are not running or SQL role permissions are missing
  • App Control Server/App Control Reporter service password was changed
  • IIS DefaultAppPool identity is not correctly set
  • CB SQL Server not meeting OER
  • Das DB was changed to a different SQL Instance without reinstalling App Control application
  • Other

Resolution

  1. Log in to the application server hosting the Console as the Carbon Black Service Account.
  2. Verify whether the Console can be accessed locally from the App Control server by going to: https://localhost/login.php
    • If this works, it could indicate there may be a networking/DNS misconfiguration.
    • Verify IPv6 is enabled (disabling it could also negatively affect performance).
  3. Verify the IIS Certificate bound in IIS is still valid.
  4. Verify the Carbon Black Service Account
  5. Fully re-enter the Service Account credentials in both App Control services and IIS Application Pools.
    • Verify the services and Application Pools remain running after re-entering the credentials.
    • If the Reporter Service fails to start due to 1053, follow the steps here.
  6. Temporarily stop all security software (including the Agent if installed) and verify issue persists.
  7. Verify status of SQL Server:
    1. Open the shepherd.dsn file in a text editor (by default this is in the \Bit9\Parity Server\ directory)
    2. Verify the value for SERVER= examples:
      Local SQL Server (Single Tier):
      SERVER=.

      Remote SQL Server (Two Tier):
      SERVER=\\ServerName\Instance
    3. Verify Microsoft SQL Server Native Client is installed on the application server hosting the Console
    4. Verify SQL Services are fully operational.
    5. Run SQL Server Management Studio as the Carbon Black Service Account and connect to the SQL Server.
    6. Verify the App Control database (das) exists.
    7. Verify SQL Server is meeting the minimum Operating Environment Requirements.

 

If the issue persists, provide the following logs & details to Support:

  1. Date/Time issue started occurring (did any change precede the start of it?)
  2. A copy of the IIS Logs from the last several days as a compressed (zip) file.
  3. Windows Event Viewer Logs
  4. Enable Server High Debug Logs via SQL
    1. Restart the Server and Reporter services
    2. Wait 5 minutes and capture logs.
  5. SQL Database Logs (including CB Analysis Script results).