Troubleshooting Console Unavailability
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Troubleshooting Console Unavailability

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Article ID: 286048

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Updated On:

Products

Carbon Black App Control (formerly Cb Protection)

Issue/Introduction

Error when launching App Control Console:

  • "The Carbon Black App Control console cannot connect to the database. Ensure that the database server is running. If the issue persists, contact Carbon Black technical support."
  • "The Cb Protection Console cannot connect to the database. Ensure that the database server is running. If the issue persists, contact Carbon Black technical support."
  • "Fatal Error: The Carbon Black App Control Console cannot connect to the database. Ensure that the database server is running. If the issue persists, contact Carbon Black support"
  • "Network error while trying to communicate with Carbon Black App Control Server"
  • "Error: Could not connect to host"
  • ERR_CONNECTION_RESET, ERR_ABORTED or similar error message

Environment

  • App Control Console: All Supported Versions
  • Microsoft Windows Server: All Supported Versions

Cause

  • Network connectivity to SQL server has been disrupted (Two Tier Environments)
  • SQL Server services are not running or SQL role permissions are missing
  • App Control Server/App Control Reporter service password was changed
  • IIS DefaultAppPool identity is not correctly set
  • CB SQL Server not meeting OER
  • Das DB was changed to a different SQL Instance without reinstalling App Control application
  • Other

Resolution

  1. Log in to the App Control Server as the Carbon Black Service Account.
  2. Verify status of the App Control Server services:
    1. Start > Run > services.msc > click OK.
    2. Find App Control Server and App Control Reporter and for each:
      • Right click > Properties > Log on
      • Re-enter the Username and Password > Apply.
      • Restart the service.
  3. Verify status of SQL Server:
    1. If using Two Tier, make SQL native client is installed on the App Control Server and verify the SQL connection between the two Servers.
    2. Verify the SQL Services are fully operational.
    3. Run SQL Server Management Studio as the Carbon Black Service Account and connect to the SQL Server.
    4. Verify the App Control database (das) exists.
  4. Verify the Carbon Black Service Account has all Windows & SQL Server permissions required.
  5. Open IIS Manager > expand the server name > select Application Pools
    1. Verify DefaultAppPool shows the Identity: ApplicationPoolIdentity
      • If Server 8.10.2+ verify AppCDownloads also shows ApplicationPoolIdentity
    2. Restart the Application Pools. Confirm Status = Started.
  6. Verify the IIS Certificate bound in IIS is still valid.
  7. Confirm SQL Server is meeting OER depending the App Control Server Version installed
  8. If SQL Instance was changed, uninstall and reinstall App Control Server application, information is published in Server Installation Guide
  9. If the issue continues, collect IIS logs, high debug logs via sql, Event Viewer Logs, and SQL logs:
    1. Open SQL Server Management Studio and connect to the SQL Server.
    2. Expand Management > right-click SQL Server Logs > View > select SQL Server Log > check the Current log  > click Export