"The Carbon Black App Control console cannot connect to the database. Ensure that the database server is running. If the issue persists, contact Carbon Black technical support."
"The Cb Protection Console cannot connect to the database. Ensure that the database server is running. If the issue persists, contact Carbon Black technical support."
"Fatal Error: The Carbon Black App Control Console cannot connect to the database. Ensure that the database server is running. If the issue persists, contact Carbon Black support"
"Network error while trying to communicate with Carbon Black App Control Server"
"Error: Could not connect to host"
ERR_CONNECTION_RESET, ERR_ABORTED or similar error message
Environment
App Control Console: All Supported Versions
Microsoft Windows Server: All Supported Versions
Cause
Network connectivity to SQL server has been disrupted (Two Tier Environments)
SQL Server services are not running or SQL role permissions are missing
App Control Server/App Control Reporter service password was changed
IIS DefaultAppPool identity is not correctly set
CB SQL Server not meeting OER
Das DB was changed to a different SQL Instance without reinstalling App Control application
Other
Resolution
Log in to the App Control Server as the Carbon Black Service Account.
Verify status of the App Control Server services:
Start > Run > services.msc > click OK.
Find App Control Server and App Control Reporter and for each: