Clean uninstall of the MSP interface

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Article ID: 45862

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

How do I do a Clean Uninstall of the Clarity Microsoft Project (MSP) Interface / Integration? 

Cause

Sometimes, due to permission restrictions or other issues on the machine, some of the MSP components do not get uninstalled on their own. If that is the case, a manual uninstall is needed to remove the remaining components. Doing a clean uninstall / install is especially recommended if running into issues during an upgrade of the MSP Interface. 

Environment

Releases: All Supported Releases

Component: Clarity Microsoft Project Integration

Resolution

  1. Uninstall the following components from Control Panel (if there are any duplicates of any of the components delete those as well):

    • CA PPM Microsoft Project Interface 

    • CA PPM Schedule Connect

    • CAClarityAddin

    • Open Workbench (if installed) - Note, prior to uninstalling OWB, if you have any custom views for OWB, make sure to save these in a separate folder prior to the uninstall.

  2.  Clean out the Registry:

    • On the workstation, go to Start and type 'regedit' in the search field.

    • Select regedit.exe

    • Select File -> Export and enter a File Name to store the back-up of the registry

    • Once finished creating a backup, delete the following keys if they exist: 

      • HKEY_CURRENT_USER\Software\Niku

        1. Expand the HKEY_CURRENT_USER folder

        2. Expand the Software folder

        3. Then scroll down and check if Niku exists. 

        4. If yes, right click the Niku folder and delete it

      • HKEY_LOCAL_MACHINE\Software\Niku

        • You may need to drill down to the Wow6432 folder to get to the Niku folder depending on your bit level: HKEY_LOCAL_MACHINE\Software\Wow6432Node\Niku

          1. Expand the HKEY_CURRENT_USER folder

          2. Expand the Software folder

          3. Then scroll down and check if Niku exists.

          4. If not, also expand the Wow6432Node folder and see if Niku exists there.

          5. If yes, right click the Niku folder and delete it

        • File path in registry for 32 bit:

          • HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Niku

       Note: Some of the keys may not exist; also, deleting each key will correctly delete all of their sub keys. 

  1. Go to Add/Remove Programs again and check that there is no trace left of the products that you have removed in step 1

  2. Delete the following folders if they are still listed: 

    • C:\CA\CA PPM MSPInterface

    • C:\CA\PPM Setups

    • C:\CA\PPM\CA PPM Schedule Connect

      • Note: The folder location is dependent on where the MSP Interface was installed:

        • If you installed the 32 bit Interface, the folders may be instead found in: C:\Program Files (x86)

        • If you installed the 64 bit Interface, the folders may be instead found in: C:\Program Files

  1. Clean out Visual Basic:

    • In MSP, go to View > Macros > Visual Basic Editor

    • Expand ProjectGlobal, Expand Modules

    • Delete the modules that start with either CA_ and Niku_ (Right click the module and select 'Remove ...' 

    • Click ‘No’ to the message that pops up ‘Do you want to export <Module Name> before removing it?’ (The message is asking if you want to export the files, which is not needed)

    • Expand Microsoft Project Objects, Double-click on Thisproject

    • Select everything in the right panel and delete it

    • Save and exit VB

  2. Verify the correct Trust Center Setting is set:

    • Go to File > Options> Trust Center > Trust Center Settings

    • Make sure "Enable all macros" is selected

  3. Reinstall the MSP Interface.

    • Ensure the bit level of the MSP Interface being installed matches that of MSP. See KB MSP bit level installed - steps to determine (includes which Clarity Integration bit level should be installed based on the MSP bit level.)

    • Also make sure the version being installed is the same version and patch level as that of Clarity. Clarity be found in Clarity by going to Home->Account Settings->Software Downloads.

  4. If using a proxy, reenter the Proxy Host and Proxy Port in the setup window in MSP. See the steps to renter proxy details found in KB: Opening MSP stops at 'Connecting to PPM' step / unable to log in to MSP Interface

Additional Information

MSP Integration - Master KB of Known Issues

MSP Integration Known Defects - Master KB

Attachments