processes probe: Internal error: Unable to find any processes
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processes probe: Internal error: Unable to find any processes

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Article ID: 34291

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) Unified Infrastructure Management for Mainframe CA Unified Infrastructure Management SaaS (Nimsoft / UIM)

Issue/Introduction

processes probe throws error: "Internal error: Unable to find any processes" and we would like to know how to resolve it.

Environment

  • UIM: any version
  • Component: UIMPRO
  • processes probe: any version

Cause

- possibly multiple solutions, see resolution section

Resolution

There are a number of options to handle this depending on the situation.

Try 'a)' first:

a) Enable the retry mechanism.

To enable the retry mechanism, make sure that you are running version 3.64 or above. Then edit the config file in Raw Configure mode. In the setup section there is a key "retry_discover_limit" which has to be set to the number of retries required. Please try to configure this key to 2 or 3 retries and let us know the results. (The maximum value is 10 retries - beyond this the probe will limit itself to 10.)

b) In some cases, the user account which runs the robot does not have permission to use /dev/null but this usually involves the symptom of the probe not being able to start.

c) On some Unix systems we do not have access to the pstat command that the Nimsoft processes probe uses by default to list the processes.
    Using Raw Configure we can force the probe to use the /usr/bin/ps to gather information rather than using the systems pstat interface.

- Use Raw Configure to set "use_perf = no" in the setup section of the configuration to force the probe to use /usr/bin/ps to gather information rather than using the systems pstat interface.

Raw Configure is accessed by selecting the probe and holding down the SHIFT key, then rt-click to select Raw Configure.

If the key does not exist, ADD the key to the setup section, setting it to no.

Additional Information

If the approach mentioned above doesn't work to eliminate the alarm, but the alarm is not repeating regularly, and/or happens infrequently, it is most likely more of just a transient error that does not require any action to resolve. In that case,

a) it can be ignored,

or

b) you can use a nas Auto Operator (AO) Profile to CLOSE the alarm after n minutes,

or

c) use the nas to run a simple script to lower the severity from Major to Informational

or

d) use a nas preprocessing rule to 'exclude' (delete) the alarm when it occurs.


Other possibly related articles:

processes probe: some processes show empty details in the status tab (broadcom.com)

processes probe sends Internal error: Unable to find any processes
https://knowledge.broadcom.com/external/article?articleId=115838

processes probe: Internal error: Unable to find any processes
https://knowledge.broadcom.com/external/article?articleId=34291

Processes running on Server but not found on Processes probe
https://knowledge.broadcom.com/external/article?articleId=130463

Processes probe goes red on a Unix robot
https://knowledge.broadcom.com/external/article?articleId=34322