ESXiホストにNSXをインストールまたはアップグレードすると、ノードがすでに存在するというエラーにより失敗する
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ESXiホストにNSXをインストールまたはアップグレードすると、ノードがすでに存在するというエラーにより失敗する

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Article ID: 426318

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VMware NSX

Issue/Introduction

免責事項:これは英文の記事「Installing or Upgrading NSX on an ESXi host fails reporting the node already exists」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。

  • インストール失敗/検証エラー: ESXiホストをトランスポートノードとして準備しているときに、次の2つのエラーのいずれかが表示されます。

    Node<node-name> with same ip <###.###.###.###> already exists

    または

    Error: General error has occurred. Discovered node with id:<Discovered Node ID:host-###> is already prepared having fabric node id:<Transport Node UUID>.
  • アップグレードの失敗: ホストのアップグレード中に次のエラーが表示されます:
Failed to get Host status for upgrade unit <Upgrade Unit ID> due to error Transport node <Transport Node UUID> not found
  • ESXi ホストは、最初に NSX から削除されることなく、vCenter から削除されました。 

  • ホストは、UI のホストおよびクラスタ セクション (システム>ファブリック>ホスト>クラスタまたはスタンドアロン)には表示されません。

  • ESXi OS を再インストールしても、IP または名前が NSX にすでに存在するため、問題は解決されません。
  • アップグレードの事前チェックが失敗し、アップグレード プロセスが一時停止する可能性があります。

  • GET API '/api/v1/transport-nodes/########-######-######-######-############/state' を実行すると、以下の結果が表示されます:

      "node_deployment_state" : {
        "state" : "failed",


        "details" : [ {

          "sub_system_id" : "########-######-######-######-############",

          "state" : "failed",

          "failure_message" : "Failed to uninstall the software on host. Host OS version not found.\n",

          "failure_code" : 26020

        } ]

      },

      "deployment_progress_state" : {

        "progress" : 40,

        "current_step_title" : "Removing NSX bits"

: トランスポート ノードは、NSX VIB で準備されたホストです。

Environment

  • VMware NSX 9.0.0
  • VMware NSX 4.x
  • VMware NSX-T Data Center 3.x

Cause

最初に NSX を削除せずに ESXi ホストを vCenter から直接削除すると、そのホストのエントリが NSX データベースに残る可能性があります。

単一のホストから NSX を削除する正しい手順:

注: これは「古いホスト」とも呼ばれ、同じ名前を使用して更新されたホストまたは新しいホストを再度追加することを防ぎます。

Resolution

この問題は Broadcom downloads から入手できる NSX 4.2.3 および 9.0.1 で解決されています 。

ソフトウェアの検索やダウンロードに問題がある場合は、Download Broadcom products and software KB をご確認ください。

 

回避策:

環境はさまざまな手順を実行することでこの状態に到達している可能性があるため、試す必要がある回避策オプションがいくつかあります。

インストール失敗の前提条件

次のオプションに進む前に、インストール/アップグレードに失敗したホストを vSphere クラスターから移動し、vSphere 内のスタンドアロン ホストにします。

次に、以下のオプションを 1 から 4 の順に実行します。

アップグレード失敗の前提条件

必要なアクションはありません。以下のオプションを 1 から 4 の順に実行してください。

オプション 1

  1. NSX UI で、次のページで影響を受けるホストが見つかるかどうかを確認します。

      システム > ファブリック > ホスト > クラスタ
      システム > ファブリック > ホスト > その他のホスト
      システム > ファブリック > ホスト > スタンドアローン

  2. ここに ESXi ホストが存在する場合は、それを選択し、「NSX の削除」をクリックして、「強制的に削除」を選択します。

  3. 強制削除が完了すると、ESXi ホストを vSphere クラスターに再度追加できるようになります。

  4. ホストが存在しない場合は、オプション 2に進んでください。オプション 2を既に完了し、再インデックス後にオプション 1を再試行しても問題が解決しない場合は、オプション 3に進んでください。

オプション 2

場合によっては、検索インデックスの失敗により、ホストが NSX UI に表示されないことがあります。

  1. 3つのNSX Managerノードすべてに管理者ユーザーとしてログインし、以下の3つのコマンドを実行します。2つ目のコマンドを実行する前に、再同期/再インデックスが完了していることを確認してください。詳細については、KB「NSX Manager UI displays notification "Failed to fetch System details. Please contact the administrator. Error: null (Error code: 513002)"」をご確認ください。

    start search resync policy
    start search resync manager
    start search resync telemetry

  2. 上記のコマンドを実行した後、再インデックスが完了するまでしばらくお待ちください。これは環境の規模によって異なりますが、少なくとも10分はかかります。
    注: 再インデックスの実行中、NSX UIにインデックス作成に関するエラーが表示され、後で再試行するように指示される場合があります。これは、インデックス作成が進行中であるため、想定内の動作です。

  3. ホストがまだリストされている場合は、次のコマンドを使用してインデックスを更新してください:

    start search resync all
  4. 再インデックスが完了するまでしばらくお待ちください。環境の規模によっては、時間がかかる場合があります。
    再インデックス中は、NSX UI にインデックス作成の通知が表示されます。 
  5. 再インデックスが完了したら、少なくとも 10 分後にオプション 1に戻り、そこでの手順を再度実行します。

     

オプション 3
オプション 1 とオプション 2 を完了してもホストが NSX UI に表示されない場合は、削除を可能にするために、次の API 手順を使用してトランスポート ノードを削除できます。

  1. 次の API 呼び出しを実行します:

    GET https://<NSX Mgr IP>/api/v1/transport-nodes/<UUID>/state. 

    注: UUID>エラーメッセージに記載されているトランスポートノードのUUIDに置き換えてください(「Issue/Introduction」セクションを参照)。NSXマネージャノードのIPアドレスまたはFQDNに置き換えてください。<NSX Mgr IP>

  2. APIレスポンスの state 値が「Object Not found」でない場合は、オプション 3 のステップ 3 に進みます。
    :state の値は、 ホストが正常に削除されたときの値である Object Not found である必要があります。

  3. NSX-T 3.2.x および 4.x の場合、次の API 呼び出しを実行します:
     DELETE https://<NSX Mgr IP>/api/v1/transport-nodes/<UUID>?force=true&unprepare_host=false
    注:  <UUID> をエラーメッセージに記載されているトランスポートノードのUUIDに置き換えてください(「Issue/Introduction」セクションを参照)。
    <NSX Mgr IP> をNSX マネージャノードの IP アドレスまたは FQDN に置き換えてください。
    curlを使用してこのAPIを実行する場合は、URL全体を二重引用符で囲む必要があります。

  4. 5 分待ってから、オプション 3 の ステップ 1に示すように、GET トランスポート ノード状態コマンドを、 "Object Not found" が返されるまで定期的に再度実行します。
  5. GET API が "Object Not found" を返したらホストを元のクラスタに戻して NSX 用に準備します。トランスポートノードプロファイルが適用されている場合は、ホストの準備が自動的に開始されます。そうでない場合は、引き続きトランスポートノードを以前と同じように準備してください。

オプション 4

オプション 3 を完了してもトランスポート ノードがクリアされない場合は、受信したエラーのトランスポート ノード ID を使用して、次の API 呼び出しを使用できます。

  1. 次の API 呼び出しを実行します:
    GET https://<NSX Mgr IP>/policy/api/v1/infra/sites/default/enforcement-points/default/host-transport-nodes/<NSX Transportnode ID>?force=true&unprepare_host=false
    :<NSX Transportnode ID> をエラーで受け取ったノード ID に置き換えてください。 
    <NSX Mgr IP> NSX マネージャノードの IP アドレスまたは FQDN に置き換えてください。

  2. APIレスポンスの状態値が「Object Not found」でない場合は、オプション 4 のステップ 3 に進みます。

    : ホストが正常に削除された場合、state 値は「Object Not found」になります。

  3. NSX-T 3.2.x および 4.x の場合、次の API 呼び出しを実行します:
    DELETE https://<NSX Mgr IP>/policy/api/v1/infra/sites/default/enforcement-points/default/host-transport-nodes/<NSX Transportnode ID>?force=true&unprepare_host=false 
  4. 5 分待ってから、オプション 4 のステップ 1 に示すように、GET トランスポート ノード状態コマンドを、 「Object Not found」というメッセージが返されるまで定期的に再度実行します。

  5. GET APIが「Object Not found」を返したら、ホストを元のクラスタに戻してNSX用に準備します。トランスポートノードプロファイルが適用されている場合は、ホストの準備が自動的に開始されます。そうでない場合は、これまでと同様にトランスポートノードの準備を続行してください。

Note: クラスターがセキュリティのみの場合、vLCM を使用して準備されている場合、またはサービス挿入がインストールされている場合は、トランスポート ノード プロファイルをデタッチすることはできません。
このような状況では、NSX をアンインストールするには、クラスタ全体から NSX を削除するか、単一のホストを NSX 準備済みクラスタから vCenter のデータセンター レベルに移動します。
ホストが NSX 準備済みクラスタの一部でなくなったら、NSX GUI を使用して NSX を削除できます。
いずれのオプションでも問題が解決しない場合は、以下の追加情報セクションに記載されている情報を収集し、Broadcom Support にテクニカル サポート ケースを開いてさらに調査を依頼してください。また、この KB 記事を参照してください。

詳細については、Creating and managing Broadcom support cases.を参照してください。

Additional Information

この問題について Broadcom サポートに問い合わせる場合は、タイムリーな対応と解決を図るために、次の情報を提供してください。:

  • NSXバージョン.
  • 問題はアップグレード中またはインストール中に発生しましたか?
  • すべての回避策オプションは完了しましたか? 完了していない場合は、どのオプションが完了しなかったか、完了しなかった理由、または完了を妨げた問題は何か?
  • NSX Manager ログ バンドル.
  • トランスポート ノードとして構成できなかったホストの ESXi ホスト ログ バンドル.
  • 調査とスクリーンショットに関連する NSX GUI またはコマンド ラインに表示されたエラー メッセージのテキスト.

Broadcom サポートによるオフライン レビュー用のログ バンドルの処理


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