Troubleshooting Console Unavailability
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Troubleshooting Console Unavailability

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Article ID: 286048

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Updated On:

Products

Carbon Black App Control (formerly Cb Protection)

Issue/Introduction

Error when launching App Control Console:

  • "The Carbon Black App Control console cannot connect to the database. Ensure that the database server is running. If the issue persists, contact Carbon Black technical support."
  • "The Cb Protection Console cannot connect to the database. Ensure that the database server is running. If the issue persists, contact Carbon Black technical support."
  • "Fatal Error: The Carbon Black App Control Console cannot connect to the database. Ensure that the database server is running. If the issue persists, contact Carbon Black support"
  • "Network error while trying to communicate with Carbon Black App Control Server"
  • "Error: Could not connect to host"
  • ERR_CONNECTION_RESET, ERR_ABORTED or similar error message

Environment

  • App Control Console: All Supported Versions
  • Microsoft Windows Server: All Supported Versions

Cause

  • Network connectivity to SQL server has been disrupted (Two Tier Environments)
  • SQL Server services are not running or SQL role permissions are missing
  • App Control Server/App Control Reporter service password was changed
  • IIS DefaultAppPool identity is not correctly set
  • CB SQL Server not meeting OER
  • Das DB was changed to a different SQL Instance without reinstalling App Control application
  • Other

Resolution

  1. Log in to the App Control Server as the Carbon Black Service Account.
  2. Verify network connectivity between App Control Server and  App Control SQL Server (if Two Tier).
  3. Verify status of App Control Server, App Control Reporter, and SQL Server services:
    1. Start > Run > services.msc > click OK.
    2. Find "App Control Server", "App Control Reporter", and "SQL Server" service:
    3. Confirm status is "running" for each service
    4. Right click "App Control Server" service > Properties > log on tab
    5. Fill in password, click "apply"
    6. Right click "App Control Reporter" service > Properties > log on tab
    7. Fill in password, click "apply"
  4. Verify the Carbon Black Service Account has all Windows & SQL Server permissions required
  5. Verify IIS identity for the DefaultAppPool
  6. Verify the IIS Certificate bound in IIS is still valid
  7. Confirm SQL Server is meeting OER depending the App Control Server Version installed
  8. If SQL Instance was changed, uninstall and reinstall App Control Server application, information is published in Server Installation Guide

If the issue persists, open a case with Support and provide the:

    1. Historical Server Logs 
    2. Event Viewer logs from the App Control Application and App Control SQL Server
    3. SQL Server logs
    4. Screenshot(s) of the relevant errors