vmnic によって報告された ESXi ホストの予期しないリンク状態の変化を調査する方法
search cancel

vmnic によって報告された ESXi ホストの予期しないリンク状態の変化を調査する方法

book

Article ID: 432908

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

免責事項: これは英文の記事 「How to investigate unexpected link state changes reported by one or more vmnic in ESXi hosts (376568)」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。

1 台以上の ESXi ホストに関連付けられた物理アップリンク (vmnic) について、ESXi / vCenter から予期しないリンク状態の変化が報告されることがよくあります。このような状況が発生した場合、目的はその原因を特定することです。

Environment

VMware vSphere ESXi

Cause

  • ESXi によって報告されるリンク状態変更イベント(直接報告と vCenter イベント経由の両方)の最も一般的な原因は、アップリンク(vmnic)に関連付けられたデバイスドライバによって検出されたリンク状態の変化です。
  • この変化は、「アップ」から「ダウン」、または「ダウン」から「アップ」のいずれかです。
  • この変化が VMware 管理者によって行われていない場合(例えば、「esxcli network nic down -n vmnicN」(N は vmnic 番号)などのコマンドを使用して行われていない場合)、まず ESXi ホストのログを確認します。

Resolution

これらのイベントについてホストが記録した内容を明らかにするための手順は次のとおりです。

  1. ESXiホストにルート権限でSSH接続します。
  2. ディレクトリを /var/run/log に変更します (例: cd /var/run/log)
  3. vmksummary.log(または以前のvmksummaryの.gzローテーション)から最新の再起動イベントの日付/時刻を取得します。

    cat vmksummary.log | grep boot

    出力は次のようになります。

    [YYYY-MM-DDTHH:MM:SS] bootstop[2104778]: Host has booted

    注意: VMware ログの「Z」で終わるタイムスタンプは Zulu Time (UTC: 協定世界時) です。よりローカル タイム ゾーンに近いタイム ゾーンに変換するには、https://www.timeanddate.com/ などのサイトを参照し、そのツールを使用してローカル分析に適したタイム ゾーンに変換してください。
    日本標準時は UTC+9 です。

  4. 次のようなコマンドを使用して最新の vobd.log を調べます。

    cat vobd.log | grep "linkstate"

    出力は次のようになります。

    [YYYY-MM-DDTHH:MM:SS]: [netCorrelator] 7891198507416us: [vob.net.vmnic.linkstate.up] vmnic vmnic2 linkstate up
    [YYYY-MM-DDTHH:MM:SS]: [netCorrelator] 7891187367545us: [esx.clear.net.vmnic.linkstate.up] Physical NIC vmnic2 linkstate is up
    [YYYY-MM-DDTHH:MM:SS]: [netCorrelator] 7908515995969us: [vob.net.vmnic.linkstate.up] vmnic vmnic2 linkstate up
    [YYYY-MM-DDTHH:MM:SS]: [netCorrelator] 7908592002230us: [vob.net.vmnic.linkstate.up] vmnic vmnic2 linkstate up
    [YYYY-MM-DDTHH:MM:SS]: [netCorrelator] 7908594078919us: [vob.net.vmnic.linkstate.up] vmnic vmnic2 linkstate up
    [YYYY-MM-DDTHH:MM:SS]: [netCorrelator] 7908601139619us: [vob.net.vmnic.linkstate.up] vmnic vmnic2 linkstate up
    [YYYY-MM-DDTHH:MM:SS]: [netCorrelator] 7908606286740us: [vob.net.vmnic.linkstate.down] vmnic vmnic0 linkstate down
    [YYYY-MM-DDTHH:MM:SS]: [netCorrelator] 7908606751860us: [vob.net.vmnic.linkstate.up] vmnic vmnic0 linkstate up
    [YYYY-MM-DDTHH:MM:SS]: [netCorrelator] 7908606751887us: [vob.net.vmnic.linkstate.up] vmnic vmnic2 linkstate up
    [YYYY-MM-DDTHH:MM:SS]: [netCorrelator] 7908608200269us: [vob.net.vmnic.linkstate.up] vmnic vmnic2 linkstate up

  5. さらに詳しい確認が必要な場合は、次のようなコマンドを使用して vmkernel.log ファイルを確認できます。

    cat vmkernel.log | grep vmnic2 | egrep "Link is down|Link is up" | less

    出力は次のようになります。

    [YYYY-MM-DDTHH:MM:SS] cpu4:2101725)i40en: i40en_UpdateUplinkLinkStatus:6857: Link is down for device vmnic2
    [YYYY-MM-DDTHH:MM:SS] cpu4:2101725)i40en: i40en_UpdateUplinkLinkStatus:6857: Link is up at 10000 Mbps Full Duplex for device vmnic2
    [YYYY-MM-DDTHH:MM:SS] cpu20:2101725)i40en: i40en_UpdateUplinkLinkStatus:6857: Link is down for device vmnic2
    [YYYY-MM-DDTHH:MM:SS] cpu20:2101725)i40en: i40en_UpdateUplinkLinkStatus:6857: Link is up at 10000 Mbps Full Duplex for device vmnic2
    [YYYY-MM-DDTHH:MM:SS] cpu12:2101725)i40en: i40en_UpdateUplinkLinkStatus:6857: Link is down for device vmnic2
    [YYYY-MM-DDTHH:MM:SS] cpu12:2101725)i40en: i40en_UpdateUplinkLinkStatus:6857: Link is up at 10000 Mbps Full Duplex for device vmnic2
    [YYYY-MM-DDTHH:MM:SS] cpu12:2101725)i40en: i40en_UpdateUplinkLinkStatus:6857: Link is down for device vmnic2
    [YYYY-MM-DDTHH:MM:SS] cpu12:2101725)i40en: i40en_UpdateUplinkLinkStatus:6857: Link is up at 10000 Mbps Full Duplex for device vmnic2
    [YYYY-MM-DDTHH:MM:SS] cpu28:2101725)i40en: i40en_UpdateUplinkLinkStatus:6857: Link is down for device vmnic2
    [YYYY-MM-DDTHH:MM:SS] cpu28:2101725)i40en: i40en_UpdateUplinkLinkStatus:6857: Link is up at 10000 Mbps Full Duplex for device vmnic2

  6. 出力がこのように表示される場合、vmnic が接続されている物理スイッチから受信した情報に基づいて、ドライバーがこれらのリンク状態の変更を記録したと想定できます。
  7. 次のステップとして、vmnic 外部のネットワーク インフラストラクチャを管理する組織のチームにこの情報を提供してください。
  8. 指定された日付/時間にすべてのインフラストラクチャを調査するように依頼します。
  9. ESXi ログから追加のサポート情報を確認したい場合は、この KB で詳細情報を入手できます --> Network adapter (vmnic) is down or fails with a failed criteria code

    具体的には、KB の解決セクションにある "The following are the failed criteria codes." というセクションが非常に役立ちます。

  10. さらにサポートが必要な場合:
    影響を受ける ESXi ホストのログ バンドルを収集します (参考: VMware ESXi の診断情報の収集)。
    サポートケースを開き、ログをケースに添付します(参考: Broadcom ケース管理ポータルでファイルをケースにアップロードする方法