MSP Target error or Clarity Addin missing due to wrong bit level
search cancel

MSP Target error or Clarity Addin missing due to wrong bit level

book

Article ID: 4225

calendar_today

Updated On: 04-08-2025

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

When opening Microsoft Project/MS Project (MSP), you receive one of two Target errors where the error line reads either: 

  • Error: Project cannot open the file.
  • Error: Openfromdatabase

Additional symptoms you may see:

  • Sometimes the CA Clarity Addin tab / menu does not appear at all.
  • After you start MS Project you don't see the Clarity PPM MSP Interface/Integration tab / it's not visible after the installation.
  • Checking the Visual Basic section of MSP, the CA VB components are not showing. 
  • You are unable to install the Microsoft Project Connector and Schedule Connect successfully due to this issue.

Environment

Release:  All Supported Releases

Cause

This is typically due to the wrong MSP Interface bit-level being installed. The MSP Interface bit-level must match that of Microsoft Project. Example, if MSP's bit level is 64 bit, then the 64-bit level MSP interface should be installed.

To see which bit level your MSP is using see MSP bit level installed - steps to determine.

Resolution

  1. Perform a Clean Uninstall of the MSP Interface
  2. Reinstall the MSP Interface with the correct version (that matches Clarity) and bit-level (that matches MSP)
  3. This can be installed from Clarity in Home->Account Settings->Software Downloads:
    • If your Microsoft Project Bit level is 32 bit download Microsoft Project Interface (x86)
    • If your Microsoft Project Bit level is 64 bit, download Microsoft Project Interface (x64)

Additional Information