MSP downloading gets stuck at opening xml - error: "serious error"
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MSP downloading gets stuck at opening xml - error: "serious error"

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Article ID: 217835

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

Microsoft Project (MSP) project plan on downloading gets stuck at opening xml though it appears the xml fully loads.

You may see a message "The last time you opened this project it caused a serious error" which is a generic warning MSP generates when there was an issue the last time the project opened that causes MSP to crash.

For steps on how to enable XML if it is not being generated automatically in the workstation's documents folder, see XML, MPP and MSP Logs for Troubleshooting MSP Issues

Environment

Release : 15.8

Cause

This issue appears to be due to copying and pasting of entire task rows. While this is supported starting in 15.7.1, there is one defect fixed in 15.9.1 patch 1 and 15.9.2 that appears to be causing this issue. MSP: Copying entire task rows duplicates or moves some tasks

In the XML, you may see that certain tasks have duplicate UID values. 

Resolution

This issue should no longer be reproducible in 15.9.1 patch 1 and 15.9.2 and higher. If you still see any issues, contact Broadcom Support.

Workaround:

Remove the project from prdocument table or delete duplicate tasks from Clarity 

Note: After implementing the fix

  1. Users who previously attempted to open the project may still see the below message since the last time the project didn't open successfully.
    • "The last time you opened this project it caused a serious error"
  2. Click Yes to the message to proceed with opening the project.

Additional Information