ALERT: Some images may not load properly within the Knowledge Base Article. If you see a broken image, please right-click and select 'Open image in a new tab'. We apologize for this inconvenience.

Roadmap sync is not working - custom values not synced

book

Article ID: 212558

calendar_today

Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

The values of the custom investment /attributes / fields do not get synced.

Cause

There could be an issue with the Clarity app cache.

Environment

Release : All Supported

Component : CLARITY ROADMAPS

Resolution

  1. In the logging, add the component: com.ca.ppm.rdm at the Debug level (See Roadmap debug logs for troubleshooting for steps to enable)
  2. Restart the app and BG services
  3. Click the roadmap Sync Items button and confirm the following lines are added in the BG log:

    DEBUG 2021-04-08 08:14:00,045 [Dispatch RDM_ITEMS_SYNC : [email protected]<server> (tenant=clarity)] rdm.sync (clarity:admin:xxxx:RDM_ITEMS_SYNC) RoadmapItemsSyncJob -> job started..
    DEBUG 2021-04-08 08:14:00,045 [Dispatch RDM_ITEMS_SYNC : [email protected]<server> (tenant=clarity)] rdm.sync (clarity:admin:xxxx:RDM_ITEMS_SYNC) RoadmapItemsSyncJob -> Reading job parameters.
    DEBUG 2021-04-08 08:14:00,107 [Dispatch RDM_ITEMS_SYNC : [email protected]<server> (tenant=clarity)] rdm.sync (clarity:admin:xxxx:RDM_ITEMS_SYNC) Sync roadmap items parameter scenario_id=5002001
    DEBUG 2021-04-08 08:14:00,107 [Dispatch RDM_ITEMS_SYNC : [email protected]<server> (tenant=clarity)] rdm.sync (clarity:admin:xxxx:RDM_ITEMS_SYNC) Sync roadmap items parameter sync_attributes=null
    DEBUG 2021-04-08 08:14:00,107 [Dispatch RDM_ITEMS_SYNC : [email protected]<server> (tenant=clarity)] rdm.sync (clarity:admin:xxxx:RDM_ITEMS_SYNC) Sync roadmap items parameter sync_cust_attrs=true
    DEBUG 2021-04-08 08:14:00,107 [Dispatch RDM_ITEMS_SYNC : [email protected]<server> (tenant=clarity)] rdm.sync (clarity:admin:xxxx:RDM_ITEMS_SYNC) Sync roadmap items parameter sync_assignments=false
  4. Run the below query to make sure the values are updated:
    select  * from odf_ca_rdm_roadmap_item

Additional Information

See also: Roadmap debug logs for troubleshooting