Unable to open project in MSP if CA Clarity addin is inactive (AppData needs to be cleared)
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Unable to open project in MSP if CA Clarity addin is inactive (AppData needs to be cleared)

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Article ID: 124102

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

When you're in a project and you try to open your scheduler in Microsoft Project (MS Project/MSP), nothing happens.

You notice one or more of the below symptoms:

  • The MSP plugin/ CA Clarity Addin in MSP is showing as inactive. 
  • The CA Clarity/PPM Integration tab is not visible / CA PPM Integration tag not available
  • 'caclarityaddin' gets unloaded / ribbon is gone every time MSP is launched
  • Because the integration tab is not available, unable to perform options such as save plan back to Clarity

Environment

Release: All supported Releases

Cause

This can happen if the addin becomes inactive. To Verify if the addin is inactive (versus disabled):

  1. In MSP, go to File->Options
  2. Click on 'Add-Ins' on the left hand menu
  3. Check the Inactive Application Add-ins section on the right hand side
  4. If the Clarity Add-In is listed in the inactive section review the Resolution steps of this article

Resolution

Delete the below 2.0 folder after creating a backup of the folder.

  1.  Open C:\Users\%USERNAME%\AppData\Local\Apps
    If you can't see the AppData folder:
    1. Go to Organize->Folder and Search Options->View->
    2. Select radio button 'Show hidden folders, files and drives'
    3. Click OK to see the AppData folder
  2. Delete the 2.0 folder after creating a backup
  3. Install the CAClarityAddin:
    1. Navigate to the following folder directory: CA\Clarity\CA Clarity PPM MSPInterface\addin
    2. Double click setup.exe to run through the install process for the Addin  

Additional Information

If the above doesn't help, see also: