MSP 'Project Save Failed' due to Task Start or Finish Date issues

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Article ID: 5264

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

When saving back a project from Microsoft Project (MSP) to Clarity using the MSP Plugin / Interface, receive error: 'Project Save Failed' due to one or more issues with Start and / or Finish Dates for tasks in MSP.

In the app-ca.logs, you see the following Warning message 'ImportTaskProcessor.doProcess(): Illegal Task Start and/or Finish dates' related to schedulers.postProject.
Tip: To get to the app-ca.logs, see the following KB that will walk both On Premise and SaaS customers on steps to retrieve the log: Access the app-ca.log or other Clarity Logs

There are a couple of causes for this issue, but below is one method to reproduce this issue:

Steps to reproduce:

  1. Export a project from Clarity to MSP
  2. In MSP, go to File->Options and set New Tasks created to Manually Scheduled using the below steps:
    1. Click on Schedule on the left hand side
    2. Set 'New tasks created' to 'Manually Scheduled'
    3. Click OK
  3. Create a new task in MSP and leave the Start/Finish Dates blank
  4. Attempt to Save the project back from MSP to Clarity

Expected Results: Project Saves successfully and the project imports successfully to Clarity

Actual Results: Receive error message 'Project Save Failed' and project does not save back to Clarity

Cause

This issue happens when there is an invalid date (or invalid date sequence) that is not supported with Clarity including:

  1. Tasks missing a Start and/or Finish date, which happens if tasks are created in MSP with Task Mode of Manually Scheduled. If the Start / Finish dates haven't been manually entered, the project will not save back to Clarity as Clarity requires Start and Finish Dates for all tasks. The value entered must be in a date format, so placeholder values such as TBD or N/A are not allowed as well.
    • To check if a task is set to Manually Scheduled, view the Task Mode icon for the task. A blue thumb tack indicates it's a manually scheduled task.
    • Screen shot below that shows a task that is manually scheduled with Blank Start and Finish Dates

 

2. The Start date of any task is greater than the Finish date of the task. The Start date of a task must be less than or equal to the task's Finish date to be able to be saved back to Clarity.

Environment

Release: All

Component: Clarity Microsoft Project

Resolution

Step 1: Check for any tasks missing Start or Finish dates (Date fields are blank or have some other type of value such as TBD or N/A) in the date fields.

If any tasks are found with this issue enter the missing dates for the task(s) in MSP (or change the Task Mode to of the task to Auto Scheduled which will automatically populate a Start and Finish date for the task)

Note: To prevent this issue going forward, ensure that the following Required setting is made for the existing project and all new projects in MSP:

  1. In MSP, go to File->Options
  2. Click on Schedule on the left hand side
  3. Set 'New tasks created' to 'Auto Scheduled'
  4. Click OK'

Note: Change Scheduling options for this project from the existing project to All New Projects to then make this the default for new projects going forward. Screen shot below:

After initial task creation, the task can then be changed to Manually Scheduled. For more details including steps to change this, see: MSP Manually Scheduled Tasks / Milestones

Step 2: Check for any tasks that have a Start date later than the task's Finish date. If any are found

Update the task dates so that the task's Start date is earlier than the task's Finish date 

Additional Information

For another known issue related to illegal start/finish date error, see MSP Project Save Failed Error due to Summary Task Start / Finish Date 

For other causes of the Project Save failed error see: MSP Project Save Failed Errors - Master KB

Clarity MSP Support Document Indexes:

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