Error: "vCenter could not authenticate with the license server" after upgrading from VCF 9.0 to 9.1
search cancel

Error: "vCenter could not authenticate with the license server" after upgrading from VCF 9.0 to 9.1

book

Article ID: 454098

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • After upgrading VCF from 9.0 to 9.1, an error messages in vCenter:

    One or more vCenter instances are not connected to a license server. To avoid service interruption, verify that the vCenter instance is connected to a license server.

  • Reviewing VCF Operations UI > Manage > Licensing > Licenses & Registration > under vCenter Systems, the following error messages appear:

    # failed assignments
    Licenses could not be synchronized with vCenters.
    Licenses could not be assigned to vCenters.

  • Clicking on View Details on the above error messages brings up a wizard to "Assign Licenses to vCenter Systems" with a Status of Failed with an error message:

    vCenter could not authenticate with the license server. Check that your NTP settings are configured correctly on the vCenter and the host where the license server is running. Please refer to KB article 424533 for more information.

  • Restarting the vCenter and license server VM does nothing to resolve the issue.
  • vCenter - /var/log/vmware/cis-license/license.log displays the following:

    2026-08-27T19:49:50.292Z INFO CISLicense 35 [vc@4413 threadName="http-nio-0.0.0.0-12080-exec-2" logger="license.licenseserver.client.http.LicenseServerHttpRequestInterceptor"] HTTP Request Header: [User-Agent: cis-license/123456789-ABCD-EFGH-IJKL-MNOPQRSTUVWXYZ]
    
    2026-08-27T20:30:13.942Z ERROR CISLicense 41 [vc@4413 threadName="http-nio-0.0.0.0-12080-exec-8" logger="managment.server.vapi.impl.LicenseServerEntitlementsDelegate"] Caught exception:
    com.vmware.cis.license.entitlement.management.exception.LicenseServerManagementException: Failed to get Entitlements [##] from License Server [##] with URL [vcflicenseserver.example.com] with response [License Server returned unexpected status code: 403 and response Forbidden]
    
    Caused by: com.vmware.cis.license.licenseserver.client.exception.LicenseServerException$UnexpectedLicenseServerException: License Server returned unexpected status code: 403 and response Forbidden
    
    Caused by: com.vmware.cis.license.licenseserver.client.http.LicenseServerHttpClientException$LicenseServerHttpResponseException
    
    2026-08-27T20:30:13.942Z ERROR CISLicense 41 [vc@4413 threadName="http-nio-0.0.0.0-12080-exec-8" logger="server.vapi.impl.util.VapiTaskUtil"] entitlement update task completed with error: com.vmware.vapi.std.errors.Error: Error (com.vmware.vapi.std.errors.error) => {
        messages = [LocalizableMessage (com.vmware.vapi.std.localizable_message) => {
        id = unused.id,
        defaultMessage = Failed to get Entitlements [##] from License Server [##] with URL [vcflicenseserver.example.com] with response [License Server returned unexpected status code: 403 and response Forbidden],
        args = [],
        params = <null>,
        localized = Failed to get Entitlements [##] from License Server [##] with URL [vcflicenseserver.example.com] with response [License Server returned unexpected status code: 403 and response Forbidden]
    }],
        data = UpdateErrorInfo (com.vmware.cis.license.subscription.entitlement.entitlements.update_error_info) => {
            reason = LICENSE_SERVER_FAILURE
        },
        errorType = ERROR
    }
  • The vCenter UUID has capitalization letters in its string.
    • To check from command line:

      grep instanceUuid /etc/vmware-vpx/instance.cfg

    • To check from /var/log/vmware/cis-license.license.log

      Example:
      User-Agent: cis-license/123456789-ABCD-EFGH-IJKL-MNOPQRSTUVWXYZ]

  • The license server FQDN and DNS forward and reverse records are correctly in lowercase letters. In the above logging example, the license server FQDN is vcflicenseserver.example.com.

Environment

VCF 9.x

Cause

Uppercase lettering found in the vCenter's UUID string causes this issue.

Resolution

Currently, it is required that the vCenter UUID be in lowercase lettering for proper connection between the vCenter and license server.

To resolve this issue, modify the vCenter UUID to lowercase. Follow KB Licenses could not be assigned to vCenters, license assignment failure on VCF 9.1 due to vCenter UUID case mismatch for instructions.

Additional Information

For other possible issues, refer to KB Error: "Licenses could not be assigned to vCenters", seen during license assignment on VCF 9.1 for additional troubleshooting.