This license could not be assigned to the selected vCenter System. Check the network connection from the selected vCenter system to the license server and try again. Please refer to KB article 424533 for more information.<license_server_hostname>.example.com" is reachable from local network, vCenter and from VCF Ops.LICENSE_SERVER_FAILURE error message./storage/log/vcops/log/vcf-licensing-plugin-<uid>.logYYYY-MM-DDTHH:MM:SS.###Z NOTICE vcf-licensing-plugin ID [ops@#### threadId="#####" threadName="pool-##-thread-#" operationId=""] [com.vmware.vrops.licensing.vcf.task.AssignEntitlementTaskExecutor.executeAssignEntitlementsOnAdapterInstance] - Executed assign entitlement task on adapter instance completed with result [AssignEntitlementStatus{allocationId='#######-####-####-####-##############', vcServerGuid=#######-####-####-####-###########,vcHostname='<vcenter_hostname>.example.com', vcAdapterName='example_adapter', vcfAdapterName='<sddc_hostname>.example.com', status=LICENSE_SERVER_FAILURE}]
License service logs on vCenter show error 403./var/log/vmware/cis-license/license.logYYYY-MM-DDTHH:MM:SS.###Z INFO CISLicense ## [vc@#### threadName="http-nio-0.0.0.0-#####-exec-#" logger="license.licenseserver.client.http.LicenseServerHttpRequestInterceptor"] HTTP Request: GET http://localhost:1080/external-vecs/http1/<license_server_hostname>.example.com/443/lsc/entitlements?allocation_ids=<id>YYYY-MM-DDTHH:MM:SS.###Z INFO CISLicense ## [vc@#### threadName="http-nio-0.0.0.0-#####-exec-7" logger="license.licenseserver.client.http.LicenseServerHttpResponseInterceptor"] HTTP Response: 403 ForbiddenYYYY-MM-DDTHH:MM:SS.###Z INFO CISLicense ## [vc@#### threadName="http-nio-0.0.0.0-#####-exec-7" logger="license.licenseserver.client.http.LicenseServerHttpResponseInterceptor"] HTTP Response Body: <html><head><title>403 Forbidden</title></head>
YYYY-MM-DDTHH:MM:SS.###Z ERROR CISLicense ## [vc@4413 threadName="http-nio-0.0.0.0-#####-exec-7" logger="managment.server.vapi.impl.LicenseServerEntitlementsDelegate"] Caught exception: com.vmware.cis.license.entitlement.management.exception.LicenseServerManagementException: Failed to get Entitlements [<id>] from License Server [<server id>] with URL [<licenseserver_hostname>.example.com] with response [License Server returned unexpected status code: 403 and response Forbidden] at com.vmware.cis.license.entitlement.management.LicenseReader.getEntitlement(LicenseReader.java:167)
/storage/log/vcops/log/adapters/ManagementAdapter/ManagementAdapter_##.logYYYY-MM-DDTHH:MM:SS.###Z ERROR ManagementAdapter id [ops@### threadId="#####" threadName="vcf-licensing-assign-######" instanceId="##"] [(##) com.vmware.adapter.management.components.licensing.vcf.H.A] - Error while assigning entitlement to VC: <lowercase_uuid> at <vcenter_hostname>.example.comHowever, the HTTP header from vCenter to the License server uses an uppercase vCenter UUID. This mismatch causes the License server to throw a 403 error message.
/var/log/vmware/cis-license/license.log on vCenter:YYYY-MM-DDTHH:MM:SS.###Z INFO CISLicense ## [vc@### threadName="http-nio-0.0.0.0-####-exec-#" logger="license.licenseserver.client.http.LicenseServerHttpRequestInterceptor"] HTTP Request Header: [User-Agent: cis-license/<UPPECASE_UUID>]
Modify the vCenter UUID to lowercase by following the steps below:
instance.cfg" and "vpxd-service-spec.prop" to use lowercase letters for the vCenter GUID. /etc/vmware-vpx/instance.cfg" and update the instanceUuid value from uppercase letters to lowercase letters.vi /etc/vmware-vpx/instance.cfg"instanceUuid=########-####-####-####-############" to use lowercase letters/etc/vmware-vpx/firstboot/vpxd-service-spec.prop", and update the cmreg.serviceid value from uppercase letters to lowercase letters.cmreg.serviceid=########-####-####-####-############" to lowercase letterslsdoctor" to reflect the changes made.python lsdoctor.py -r"vcenterserver" service-control --stop --all && service-control --start --allservice-control --status --all
Note: Certain services may require few minutes to become operational. If vSphere HA reports errors after a service restart, disable HA on each cluster and wait for the removal to complete. Re-enabling HA then resolves the issue.# /usr/lib/vmware-vmafd/bin/vmafd-cli get-ldu --server-name localhostOutput: ########-####-####-####-############# /opt/likewise/bin/ldapdelete -r "cn=AssetEntity_<instanceUuid>-<LDU_ID>,cn=LicenseService,cn=Services,dc=vsphere,dc=local" -D "cn=Administrator,cn=Users,dc=vsphere,dc=local" -WAssetEntity_########-####-####-####-############-########-####-####-####-############dc=vsphere,dc=local to reflect the environment's SSO domain.<instanceUuid> is from step 4.a in upper case letters.<LDU_ID> is from Step 8.aservice-control --stop --all && service-control --start --allIf SRM is used in the environment, export the configuration data. When the vCenter GUID changes, SRM will stop functioning. Hence, needs to unregister both of them then re-register and import the xml.