This could occur when API extensibility is used and VCD acts as a proxy where VCD cell initiates outbound connections.
/opt/vmware/vcloud-director/logs/vcloud-container-debug.log contains errors such as:java.io.IOException: Too many open files.VMware Cloud Director 10.6.x
The issue is caused by the Apache HttpClient implementation, where, under certain race conditions, the close call successfully closes the socket, but the underlying file descriptor is not released.
A fix is targeted for a future patch release, which will be applicable to VCD 10.6.1 and 10.6.2.
Workaround:
To mitigate the file descriptor growth until a patch is applied:
POST /ext-ui/tenant/####/ariaops/ui/bridge/getChargebackVMsGET /ext-ui/tenant/####/ariaops/ui/heartbeat.actionPOST /ext-ui/tenant/####/ariaops/ui/metricChart.actionIf disabling the API calls is not a feasible solution.
To be updated on the fix status, subscribe to this article by following the steps in Knowledge Base Article Subscription.