/opt/vmware/vcloud-director/logs/vcloud-container-debug.log contains errors such as:java.io.IOException: Too many open filesVMware Cloud Director 10.6.x
The issue is caused by the Apache HttpClient implementation, where, under certain race conditions, the close call successfully closes the socket, but the underlying file descriptor is not released.
Raise a support request with Broadcom to request a hot patch.
Note: Applying the hot patch will upgrade the environment to 10.6.2 first before applying the Hot Patch.
Workaround:
Option 1:
Block the following API calls at the AVI Load Balancer level for these specific endpoints:
POST /ext-ui/tenant/####/ariaops/ui/bridge/getChargebackVMs
GET /ext-ui/tenant/####/ariaops/ui/heartbeat.action
POST /ext-ui/tenant/####/ariaops/ui/metricChart.action
Option 2:
To be updated on the fix status, subscribe to this article by following the steps in Knowledge Base Article Subscription.