Introduction: During a VMware Cloud Foundation (VCF) 9.1 greenfield deployment, the VCF Installer fails at the "Validate & Deploy" stage. The UI displays the error: "Unable to determine if functionality is allowed/blocked." This often occurs following a previous failed deployment attempt which leaves stale records in the platform database.
Symptoms:
/var/log/vmware/vcf/commonsvcs/vcf-commonsvcs.log show: java.net.NoRouteToHostException: route to host andTimeout connecting to <vCenter IP>Attempting to clear the error by restarting the commonsvcs service does not resolve the issue.
VMware Cloud Foundation 9.1
The issue is caused by stale vCenter Server and ESXi host entries lingering in the platform database from the previous failed deployment attempt which causes the validation processes to attempt communication with non-existent or unreachable endpoints
To resolve this issue, perform manual database cleanup OR a full re-deployment.
Note: Ensure there is a snapshot in place before proceeding with any database or destructive changes
psql -h localhost -U postgres -d platformselect * from host; select * from vcenter;