Centralized TGW deployment fails with Tier0-TGW transit subnet does not exist error - VMware NSX 9.1
search cancel

Centralized TGW deployment fails with Tier0-TGW transit subnet does not exist error - VMware NSX 9.1

book

Article ID: 450210

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

In VMware NSX 9.1, creating a VCF Automation Org results in the Centralized Transit Gateway (CTGW) failing to connect with the Tier-0 gateway. The CTGW enters a failed state immediately after creation.

Symptoms:

  • This issue is observed when the Tier-0 configuration has the 'Transit Gateway Transit subnet' field left empty, and the default global-tgw-transit-subnet-block IP block fails to be utilized automatically.
  • The following error is observed in the logs: [Routing] Tier0-TGW transit subnet does not exist on provider tier0 gateway /infra/tier-0s/<T0 LR>

 

Environment

  • VMware NSX 9.1
  • VMware Cloud Foundation 9.1
  • VCF Automation

Cause

The issue occurs when the tgw_transit_subnet_prefix_length attribute is not correctly populated in the global-config API:

https://{mp-ip}/policy/api/v1/infra/global-config

This prevents the system from assigning a unique subnet to the CTGW from the default global transit subnet block.

Resolution

A permanent resolution is targeted for a future release. Users should subscribe to this article to receive updates on the fix status.

To work around this issue, update the tgw_transit_subnet_prefix_length attribute value to the default of 23 in the global-config API using the following steps:

  1. Perform a GET API request to retrieve the current GlobalConfig from the NSX Manager: curl -k -u 'admin:<password>' -X GET 'https://<NSX-Manager-IP>/policy/api/v1/infra/global-config' -H 'Content-Type: application/json'

  2. Copy the JSON response payload.

  3. Edit the JSON payload to add the missing prefix length attribute ("tgw_transit_subnet_prefix_length" : 23) to the configuration. See the example payload format below:

{
  "mtu" : 8800,
  "fips" : {
    "lb_fips_enabled" : true,
    "tls_fips_enabled" : false
  },
  "l3_forwarding_mode" : "IPV4_AND_IPV6",
  "uplink_mtu_threshold" : 9000,
  "vdr_mac" : "02:50:56:56:44:52",
  "vdr_mac_nested" : "02:50:56:56:44:53",
  "allow_changing_vdr_mac_in_use" : false,
  "arp_limit_per_gateway" : 50000,
  "external_gateway_bfd" : {
    "bfd_profile_path" : "/infra/bfd-profiles/default-external-gw-bfd-profile",
    "enable" : true
  },
  "lb_ecmp" : false,
  "remote_tunnel_physical_mtu" : 8900,
  "physical_uplink_mtu" : 8900,
  "global_replication_mode_enabled" : false,
  "is_inherited" : false,
  "site_infos" : [ ],
  "default_host_switch_mode" : "ENS_INTERRUPT",
  "tgw_transit_subnet_blocks" : [ "/infra/ip-blocks/global-tgw-transit-subnet-block" ],
  "tgw_transit_subnet_prefix_length" : 23,                                                     <<<< To insert <<<
  "resource_type" : "GlobalConfig",
  "id" : "global-config",
  "display_name" : "default",
  "path" : "/infra/global-config",
  "relative_path" : "global-config",
  "parent_path" : "/infra",
  "remote_path" : "",
  "unique_id" : "######-######-######-######-######",
  "realization_id" : "######-######-####-######-######",
  "owner_id" : "######-######-####-######-######",
  "marked_for_delete" : false,
  "overridden" : false,
  "_create_time" : 0,
  "_create_user" : "unknown",
  "_last_modified_time" : 1779304942116,
  "_last_modified_user" : "admin",
  "_system_owned" : false,
  "_protection" : "NOT_PROTECTED",
  "_revision" : 3
}

If you need further assistance, see Contact Support.

Additional Information

You can also resolve the issue by configuring the Transit Gateway Transit subnet in the T0 LR . Ref:  Add an NSX Tier-0 Gateway.

If additional assistance is needed with troubleshooting, reach out to Broadcom support by creating a support case using the instructions at Creating and managing Broadcom support cases.