VCFA patching hangs at "Initiate product patching"
search cancel

VCFA patching hangs at "Initiate product patching"

book

Article ID: 448078

calendar_today

Updated On:

Products

VCF Automation VCF Operations

Issue/Introduction

You are attempting to patch VCF Automation via VCF Operations and it is hung at "Initiate product patching"
After some time the upgrade task may fail with an error indicating that it is trying to use the short name for the Fleet Manager appliance when pulling the update bundle rather than its FQDN
Fleet Manager shows the short name when running 'hostname -f' via ssh.

Environment

VCF Automation 9.0.x
VCF Operations 9.0.x
VCF Operations Fleet Manager 9.0.x

Cause

Fleet Manager needs to be configured using the FQDN

Resolution

The hostname of Fleet Manager cannot be updated and it will need to be re-deployed using the FQDN instead of the short name. 

Workaround:
As a workaround, until you can redeploy Fleet Manger with the FQDN, you can retry the failed upgrade task and specify the patching location using the FQDN for the Fleet Management VM.

Resolution:
Redeploy Fleet Manager appliance using the FQDN

  1. Take snapshots for VCF Operations and Fleet Management as per below KB:
    How to create a snapshot for VCF Operations Fleet Manager appliance 

  2. Un-Register Fleet Manager from Operations
    1. Log in to the VCF Operations user interface.
    2. Navigate to Fleet Management > Lifecycle > VCF Management > Components.
    3. Locate the existing VCF Fleet Manager or related VCF instance, click the vertical ellipsis (three dots), and select Delete.
    4. If the Delete option on the Fleet Management UI is not available follow the steps in the KB Troubleshooting VCF Operations fleet management node Integration Failures in the VCF Operations 
      Important: Ensure that the option to delete the actual virtual machine from vCenter is not selected.
    5. Shut down the old Fleet Manager virtual machine and power them off.

  3. Redeploy Using FQDN
    Deploy a new Fleet Manager appliance as per the documentation at Deploy the VCF Operations fleet management Appliance
    Important: When redeploying, verify that your hostname matches a resolvable FQDN to prevent generated certificate and connection failures

  4. Connect the new Fleet Management on VCF Operations Admin UI as per the documentation at Register the VCF Operations fleet management Appliance with VCF Operations