Troubleshooting VCF Operations fleet management node Integration Failures in the VCF Operations
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Troubleshooting VCF Operations fleet management node Integration Failures in the VCF Operations

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Article ID: 402063

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Updated On:

Products

VCF Operations

Issue/Introduction

This article lays down the steps needed to troubleshoot Troubleshooting VCF Operations fleet management node 9.0  Integration Failures in the VCF Operations 9.0

Environment

VMware cloud Foundation Operations 9.x

Cause

Potential reasons for the failure include:

  • Invalid Credentials: The password provided is incorrect or does not meet the length/complexity requirement.
  • Communication Failure: There are network connectivity issues between the services.

Resolution

Note: Before performing the following procedure, ensure that you take snapshots of  VCF Operations nodes and the Fleet Management appliance.

1. Login into VCF Operations Admin UI , Click on "Disconnect" under the VCF Operations Fleet Management  section.

2. Open Swagger UI for Fleet Management by navigating to VCF Operations - Developer Center - APIs & SDKs - Fleet Management API

3. Under Environment Controller , execute 

GET /lcm/lcops/api/v2/environments


4. Fetch the Environment ID for VCF Operations and then execute the API for  deleting it from the environment. As deleting VCF Operations from UI is not possible. 

DELETE /lcm/lcops/api/environments/{environmentId}/delete

Payload
{
  "controllerType": "string",
  "deleteFromInventory": true,
  "deleteFromVcenter": false,
  "deleteLbFromSddc": true,
  "deleteWindowsVMs": true
}

5. Reconnect Fleet Management Appliance with VCF Operations. 


Note: Do not set the deleteFromVcenter property to true, as this will result in the deletion of component-based appliances from vCenter.