/var/log/vmware/vmware-updatemgr/vum-server/vmware-vum-server.log, the following error appears:code: 500(Internal Server Error); fault: (vim.fault.NoPermission) ... privilegeId = "Global.SetCustomField"
VCF 9.1.0.0
VCF 9.1.0.0100
VPX_FIELD_DEF table in the vCenter Database (VCDB) is missing privilege definitions for updatemgr attributes.Global.SetCustomField check, which is not correctly mapped for automated tasks.In the vCenter UI select the top level vCenter Server object in the inventory view.
Navigate to “Configure > Scheduled Tasks”.
Select the “VMware vSphere Lifecycle Manager Updated Download” task.
Click the “Run” button.
If it succeeds that should indicate the issue is resolved.