Error: Download patch definitions task hang in queued state after vCenter upgrade to vCenter 9.1.x.
search cancel

Error: Download patch definitions task hang in queued state after vCenter upgrade to vCenter 9.1.x.

book

Article ID: 447480

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • The scheduled task Download patch definitions remains in a "Queued" state indefinitely in the vSphere UI.
  • This issue is observed after upgrading vCenter Server from 9.0.2 to 9.1.0 or 9.1.0.0100.
  • Manual synchronization of downloads completes successfully.
  • The automated scheduled task never transitions from "Queued" to "Running."
  • In /var/log/vmware/vmware-updatemgr/vum-server/vmware-vum-server.log, the following error appears:

code: 500(Internal Server Error); fault: (vim.fault.NoPermission) ... privilegeId = "Global.SetCustomField"

Environment

VCF 9.1.0.0

VCF 9.1.0.0100

Cause

  • The VPX_FIELD_DEF table in the vCenter Database (VCDB) is missing privilege definitions for updatemgr attributes.
  • This causes the system to default to a Global.SetCustomField check, which is not correctly mapped for automated tasks.

Resolution

  1. Verify if the environment is running vCenter 9.1.x.
  2. The resolution requires proactive database modification by Broadcom Technical Support.
  3. Open a support request and reference this article. See Contact Broadcom Support.
  4. Subscribe to this article to be updated on the fix status, targeted for a future release. Reference: Subscribe to a Broadcom knowledge article.

Additional Information

Trigger scheduled task to confirm issue is resolved

  1. In the vCenter UI select the top level vCenter Server object in the inventory view.

  2. Navigate to “Configure > Scheduled Tasks”.

  3. Select the “VMware vSphere Lifecycle Manager Updated Download” task.

  4. Click the “Run” button.

  5. If it succeeds that should indicate the issue is resolved.