spooler turns red when UIM filesystem gets full
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spooler turns red when UIM filesystem gets full

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Article ID: 426900

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

The filesystem where the UIM robot is installed has filled up and the spooler probe turned red.

The robot is crashed and not sending alerts even after clearing the disk space.

Environment

DX UIM - Any Version

Cause

The spooler probe handles the queueing and sending of robot messages (QoS, discovery, and alarms) to the robot's hub.

In order to send these messages, the spooler must be able to write to the queue files (q1.rdb and q2.rdb) located in the robot folder, as well as write to the logs.

If the filesystem fills up, the spooler will be unable to write to these files which causes exceptions in the underlying C libraries that cause the probe to crash or restart repeatedly until the "max restarts" limit is reached.

Resolution

Because this is related to the underlying architecture, there is no workaround or solution.  It is important to avoid a full disk on the UIM Robot filesystem.

Therefore, we recommend ensuring that the robot's filesystem is always monitored by the CDM probe, and ensure that action is taken quickly in response to disk space alerts, in order to prevent the disk from filling up.  Additionally, it may be necessary to add additional space to the filesystem.  Broadcom recommends a minimum of 5GB of disk space for a robot.

After clearing space, the robot must be manually restarted (e.g. "service nimbus restart" on Linux, or restarting the Nimsoft Robot Watcher on Windows) and then it will recover.

If the robot does not recover from a manual restart, and the space is available, the configuration files may have been corrupted.  Follow this article if that is the case.

Additional Information

DX UIM (Nimsoft) Robot - cpu, memory, disk and bandwidth usage