Cannot connect to my hub and my controller.cfg is missing probes/truncated
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Cannot connect to my hub and my controller.cfg is missing probes/truncated

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Article ID: 35028

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) CA Unified Infrastructure Management On-Premise (Nimsoft / UIM) CA Unified Infrastructure Management SaaS (Nimsoft / UIM)

Issue/Introduction

If the primary hub cannot start and you are unable to connect to it at all, but the Services appear to be up and running, this may be due to missing probe definitions in the controller.cfg in $NIMROOT/robot directory:

This issue can happen if for example the server crashed while the controller.cfg was still locked by the Nimsoft Robot watcher process, and became corrupted or truncated. On reboot, the robot watcher service then recreated the file but it is then only containing the controller probe entry. This then causes none of the other core probes to start, and showing the hub as not started up.

Environment

Release: DX UIM 20.4 or higher
Component: Robot (controller)

Cause

  • corruption/truncation of controller.cfg

Resolution

If there is a backup copy of controller.cfg available, replace the current controller.cfg with the backup and restart the robot service.

If there is no backup copy of controller.cfg available, then follow these steps:
  1. Replace the corrupted controller.cfg with a copy from any other hub (In the zip file attached to this document you will find a sample_controller.cfg if you do not have a backup copy. If you are using Linux you will need to edit this file and remove the ".exe" from the "command = probename.exe" for all the probes listed).

  2. Remove all lines which start with 'magic_key'

  3. Move (don't copy) controller.cfg to $NIMROOT\robot\changes folder

  4. Restart the robot watcher service.

There should now be a new controller.cfg in $NIMROOT\robot folder and at least controller, hub probes should be active and green in Infrastructure Manager.
 Follow the next instructions to generate new magic keys.

If there is at least ONE directly connected hub on the same network as the primary hub:
  1. Login to the secondary hub using Infrastructure Manager

  2. On the primary hub, only the controller will be up and it will automatically attach to the nearest/secondary hub as it is running as a robot only. If it doesn't show up and attach to the secondary hub, use Connect Robot tool in Infrastructure Manager to attach the primary hub robot to the secondary hub.

  3. Once, you have the primary hub robot attached to secondary hub, validate the hub probe by right clicking on the hub probe and then select Security->Validate. After the hub probe is active it will detach from secondary hub and will take the hub role. validate the other probes in the same way as you just did with the hub probe.

If there is NO directly connected hub on the same network as the primary hub?

If the hub probe is not running: 
    1. Launch a command prompt and navigate to the $NIMROOT\hub folder and execute this command: hub.exe -d3 -lstdout

    2. Leave this running in the command window (this will launch the hub so you can log in), do not close the command prompt.

    3. Launch Infrastructure manager and login to the hub.

    4. Right click on the hub probe, choose "Security" then "Validate".

You will see a prompt asking you if you wish to activate the probe.
 
Click Yes.

Once the operation completes, you will see that the hub is up and running.
 
If the hub is already running, or after you have launched the hub as above, you will need to locate any additional "red" probes, right click each of them, and choose "Security" and then "Validate" as above.
 
Clean up:
 
This step is needed to make sure that all probes which are actually installed on the system are in sync with what you see in the Infrastructure Manager UI.
  1. Login to Infrastructure Manager

  2. Validate any/all red-lock icon probes, if any on the hub

  3. Cross reference $NIMROOT\probes folder/sub-folders and to the probes showing up in Infrastructure Manager

    1. Deploy any probe which exists on file-system under \probes\* folder

    2. Delete any probe which does not exist on file-system under \probes\* folder

Additional Information

The following Powershell Script can be used in Windows to identify all the probes which are already installed under the /probes/ folder.  You can run this script to get a list of the probes which need to be re-deployed.

# change the below line if your installation path is different
$baseDir = "C:\Program Files (x86)\Nimsoft\probes"

$subDirs = Get-ChildItem -Path $baseDir -Directory | ForEach-Object {
    Get-ChildItem -Path $_.FullName -Directory | ForEach-Object {
        $_.Name
    }
}

$subDirs | ForEach-Object { Write-Output $_ }

 

The following is a Linux/bash script which will accomplish the same thing for a Linux hub installation:

#!/bin/bash

# change the below line if your installation path is different
base_dir="/opt/nimsoft/probes/"

# Find directories one level below base_dir
find "$base_dir" -mindepth 2 -maxdepth 2 -type d | while read -r dir; do
  # Extract the last subdirectory name
  basename "$dir"
done

 

Attachments

1558534143484TEC000002846.zip get_app