MSP Target Error or Clarity Addin missing due to Wrong Bit Level

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Article ID: 4225

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Updated On:

Products

Clarity PPM On Premise

Issue/Introduction

When opening Microsoft Project/MS Project (MSP), receive one of two Target errors where the Error line reads either: 

  • Error: Project cannot open the file.
  • Error: Openfromdatabase

Sometimes the CA Clarity Addin tab does not appear at all. After I start MS Project I don't see the Clarity PPM MSP Interface/Integration tab / it's not visible after the installation. Checking the Visual Basic section of MSP, the CA VB components are not showing

Cause

This is typically due to the wrong MSP Interface bit level being installed. The MSP Interface bit level must match that of Microsoft Project. Example, if MSP's bit level is 64 bit, then the 64 bit level MSP interface should be installed.

See What bit level of MSP do I have installed?

Environment

Release:  All Supported Releases
Component:  MSP

Resolution

  1. Perform a Clean Uninstall of the MSP Interface
  2. Then reinstall the MSP Interface with the correct version (that matches Clarity PPM) and bit level (that matches MSP)
  3. This can be installed from Clarity PPM in Home->Account Settings->Software Downloads:
  • If your Microsoft Project Bit level is 32 bit download Microsoft Project Interface (x86)
  • If your Microsoft Project Bit level is 64 bit, download Microsoft Project Interface (x64)

Note: See What bit level of MSP do I have installed? for how to check the MSP Bit level installed on the workstation.

Additional Information

See also:

Clean Uninstall of the MSP Interface

See MSP Integration - Master KB of Known Issues

See MSP Integration Known Defects - Master KB

Attachments

1558691409008000004225_sktwi1f5rjvs16glu.jpeg get_app
1558691405566000004225_sktwi1f5rjvs16glt.png get_app