Segment port appears to be stuck in an 'In Progress' status in the NSX Manager UI due to 'Deletion in Progress'
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Article ID: 417871
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Updated On:
Products
VMware NSX
Issue/Introduction
Segment port appears to be stuck in an 'in progress' state in policy view of the NSX Manager UI. 'Deletion in Progress' is being reported for that port like the screenshot below:
For the affected VM, searching the NSX UI may reveal a duplicate 'Uninitialized' segment port that shares the same VIF ID (as illustrated in the screenshot). But please note that this is not always observed:
When you check the 'Last Modified Time' with the vMotion history of the VM, you might see a correlation between the modified time on the port and the time of a vMotion task against that VM.
You may see connectivity issues with the VM connected to the segment port, if allow DFW rules are configured using segment port tagging. In such a scenario in the Manager UI while in Manager view you might observe that the port is 'Up', but the tags are missing which leads to packets being dropped.
At times it is observed that the NSX Manager cluster intermittently goes into a degraded state.
Environment
VMware NSX 4.X
Cause
The issue may stem from NSX Manager cluster instability, specifically the Management Plane flapping between Up and Down states.
Suspected that port deletion/creation requests are being missed when the MP is flapping between the Manager and the host.
It has been observed in environments that have hit the following issue:
NSX Manager cluster intermittently goes into degraded state and NSX UI becomes inaccessible with error code 101
Apply one of the workarounds or the fix from KB 405048 to stabilise the Management cluster. This should prevent further incidents of ports being stuck in an 'In Progress' state. The fixed versions are available at Broadcom downloads. If you are having difficulty finding and downloading software, please review the Download Broadcom products and software KB.
Additional Information
If NSX Manager cluster instability is not observed but you still see segment ports with the same symptoms, then please open a Broadcom case referencing this KB with the following data:
NSX Manager logs
vCenter logs
Logs from the host the VM is currently residing on
Logs from the source and destination host if a vMotion is found to correlate with the modification time on the port.
Timestamp for the vMotion
Handling Log Bundles for offline review with Broadcom support: