"Failed to fetch System details. Please contact the administrator. Error: null (Error code: 513002)" notification observed in NSX UI
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"Failed to fetch System details. Please contact the administrator. Error: null (Error code: 513002)" notification observed in NSX UI

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Article ID: 410402

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Updated On:

Products

VMware NSX

Issue/Introduction

  • The NSX Manager UI displays the following error and/or the notification:
    "Failed to fetch System details. Please contact the administrator. Error: null (Error code: 513002)". 



  • You see the following log prints in NSX Manager's /var/log/nsxapi.log. 
    YYYY-MM-DDTHH:MM:SS:MSZ WARN http-nio-127.0.0.1-7440-exec-12 TransportZoneDaoHelper 3958198 FABRIC [nsx@6876 comp="nsx-manager" level="WARNING" reqId="81443883-####-####-####-049364805c51" subcomp="manager" username="admin"] Policy entity of TransportZoneProfile is null : /infra/transport-zone-profiles/vRNI-BFD_Profile_RFI######w==
    YYYY-MM-DDTHH:MM:SS:MSZ ERROR http-nio-127.0.0.1-7440-exec-12 PolicySystemOverviewServiceImpl 3958198 - [nsx@6876 comp="nsx-manager" errorCode="PM513002" level="ERROR" subcomp="manager"] Cannot fetch system details: null
    java.lang.NullPointerException: null
    YYYY-MM-DDTHH:MM:SS:MSZ ERROR http-nio-127.0.0.1-7440-exec-14 HTTPSClient 3958198 SYSTEM [nsx@6876 comp="nsx-manager" errorCode="MP193072" level="ERROR" reqId="62f196da-####-####-####-76340bcb5dfd" subcomp="manager" username="admin"] out put of the API { "httpStatus" : "BAD_REQUEST", "error_code" : 513002, "module_name" : "Policy", "error_message" : "Failed to fetch System details. Please contact the administrator. Error: null"} with http status code 400 and uri is com.vmware.nsx.common.dashboard.widgets.UrlRequest@2f####c8

Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.

Environment

VMware NSX

Cause

This error occurs due to a stale reference to a non-existent, or already deleted Transport Zone Profile in the Corfu database. 

Resolution

This is a known issue impacting VMware NSX. 

 

If you believe you have encountered this issue, and you require a workaround, open a support case with Broadcom Support and refer to this KB article.

For more information, see Creating and managing Broadcom support cases.

Additional Information

Also see KB article NSX System -> Fabric -> Hosts page does not load and the GUI reports "Search index is out of sync".