VMware Aria Suite Lifecycle Manager Upgrade Stuck at 30%
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VMware Aria Suite Lifecycle Manager Upgrade Stuck at 30%

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Article ID: 387245

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

  • During an upgrade from VMware Aria Suite Lifecycle Manager (LCM) version 8.16.x to 8.18, the process became stuck at 30% completion.

Environment

  • VMware Aria Suite Lifecycle 8.x

Cause

  • The upgrade process was hindered by RPM database corruption. The rpm -qa command, used to verify installed packages, became unresponsive, preventing the appliance from successfully validating and installing RPMs during the upgrade. This resulted in the upgrade stalling at 30%.

Resolution

Note: Take Aria Suite Lifecycle Snapshot before the activity.

Step 1Verify the status of the appliance management and workflow engine services using the below commands:

systemctl status cap-appliance-management.service 
systemctl status cap-workflow-engine.service
  • Restart the service if any service is in inactive state using systemctl restart <service-name> command

Step 2: Rebuild RPM Database: 

  • Use the rpm --rebuilddb command to rebuild the corrupted RPM database.

Step 3: Rename the workflow database using the below command:

mv /storage/lifecycle/capengine/workflow.db /storage/lifecycle/capengine/workflow.d

Step 4: And restart workflow engine service:

systemctl restart cap-workflow-engine
systemctl status cap-workflow-engine

Step 5: Take another snapshot in vCenter before retrying the upgrade.

Step 6: Start the upgrade via the Aria Suite Lifecycle UI > Lifecycle Operations > Settings > System Upgrade.

Step 7: Monitor Upgrade Progress
  • Monitor the upgrade progress by continuously tailing the log files /var/log/vmware/capengine/cap-non-lvm-update/workflow.log, /opt/vmware/var/log/vami/vami.log and /opt/vmware/var/log/vami/updatecli.log using the 'tail -f' command.
  • This time, the upgrade should go past 30% completion and should be completed eventually.

Additional Information