The 'About' page and 'System Details' pages show some blanks in place of actual values after upgrading to 8.12.x
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The 'About' page and 'System Details' pages show some blanks in place of actual values after upgrading to 8.12.x

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Article ID: 312244

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:

The 'About' page and 'System Details' pages show some blanks in place of actual values. 

The error details as seen vRSLCM log -

2023-09-29 05:38:14.081 ERROR [pool-3-thread-14] c.v.v.l.l.u.LcmCapUtil - – Response status code: 401

2023-09-29 05:38:14.081 ERROR [pool-3-thread-14] c.v.v.l.l.u.LcmCapUtil - – Failed to fetch auth token for CAP.

2023-09-29 05:38:14.081 INFO [pool-3-thread-14] c.v.v.l.p.d.l.u.LcmVaDetailsUtil - – REST call to get system settings unsuccessful: com.vmware.vrealize.lcm.lcops.common.exception.CAPException: Failed to fetch auth token for CAP.


Environment

VMware vRealize Suite Lifecycle Manager 8.x

Cause

One of the reasons for this is a wrong 'capuser' password data in LCM. One of the reasons why this happens is because the customer has set a custom password length restriction in their LCM appliance (Not in control of the LCM code), Due to which the Aria lifecycle manager internal user 'CAP user' which has a default password length of 10, becomes unusable.

Resolution

This issue has been mitigated in the 8.14 release of vRLCM - The default password length is now 16 characters.


Workaround:

How to reset the CAP user password?

1. Type out the new password in a notepad (This is needed for later steps)It is absolutely essential to have the correct password noted down for the below steps to work.

2. Go to appliance SSH, and change the password for 'cap user' to the above password using the command:

passwd capuser

3. DELETE the current 'cap user' password in the vRLCM locker using the command:

psql -h localhost --username=postgres -d vrlcm -c "DELETE FROM public.vm_locker_password WHERE alias='capuser';"

4. Add the `capuser` password to the vRLCM locker. For this first, we need to authenticate to vRLCM and get the JSESSION-ID: Use this curl command to get the JSESSIONID:

curl -s -I -k --location --request POST 'https://<lcm-ip>/lcm/authzn/api/login' --header 'Accept: application/json' --header 'Content-Type: application/json' --header 'Authorization: Basic <base64encode_value_of_admin@local:password>'

NOTE: The Authorization header above is of the format: Basic<space>Base64(<admin@local>:<password>)
Use a tool like: https://www.base64encode.org to get the base64 encoded format for the above Authorization header for the value: `admin@local:<password>`

5. Note down the JSESSION-ID in the output of the curl command from step 4. Use it to call the API to CREATE the 'cap user' password in the vRLCM locker:

curl --location 'https://<lcm-ip>/lcm/locker/api/v2/passwords' --header 'Content-Type: application/json' --header 'Cookie: JSESSIONID=<session_id>' --data '{"alias": "capuser","password": "<PASSWORD****>","passwordDescription": "password for capuser","referenced": true,"userName": "capuser"}'

The above steps should update the cap user password in both the appliance and the vRLCM application.
If the reason for the About and the System Details page showing blank values is the capuser password, the above steps will resolve the issue.