Error: "The following IP/MAC addresses have already been used by running virtual machines: MAC addresses" error when powering on a virtual machine in VMware Cloud Director
search cancel

Error: "The following IP/MAC addresses have already been used by running virtual machines: MAC addresses" error when powering on a virtual machine in VMware Cloud Director

book

Article ID: 325491

calendar_today

Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • Powering on a virtual machine in Cloud Director fails with a UI error in the form:
The following IP/MAC addresses have already been used by running virtual machines: MAC addresses: ##:##:##:##:## IP addresses: Use the Fence vApp option to use same MAC/IP. Fencing allows identical virtual machines in different vApps to be powered on without conflict, by isolating the MAC and IP address of the virtual machine.

Environment

  • VMware Cloud Director 10.x

Cause

This is expected behavior when there is a conflict of IP/MAC address between an existing/running VM with the VM being powered on inside the Organization VDC.
Additionally, this issue can occur when stale network interface (NIC) data remains in the database for a virtual machine within the vApp, causing IP and MAC address conflict checks to fail during power-on operations. This conflict check evaluates all virtual machines belonging to the vApp, including those not currently being powered on.

Resolution

To resolve the issue, follow one of the options below:

Option 1:
Correct the network configuration using the VMware Cloud Director UI

  1. Navigate to Data Centers > Select the Organization VDC containing the affected vAPP and VMs > Virtual Machines.

  2. Select the VM whose network configuration needs to be checked.

  3. Select NICs.

  4. Compare the IP Address and MAC Address displayed in VMware Cloud Director with the corresponding network adaptor shown for the VM in vCenter.

    Note: The VM reporting the power-on failure may not be the VM containing the conflicting NIC information.

  5. If incorrect or stale network information is identified, power off the virtual machine containing the incorrect NIC configuration.

  6. Return to the virtual machine in VMware Cloud Director, select the NICs tab, and click Edit.

  7. Locate the affected adaptor and in the IP Address field, enter the intended IP Address for the VM. (If a duplicate VM is utilizing the IP address, you can resolve the conflict by updating the IP mode to None).

  8. If the MAC address displayed in VMware Cloud Director does not match the expected MAC address, select Reset MAC Address for the affected NIC.

  9. Click Save.

  10. Reopen the NICs tab and confirm that the IP address and MAC address now show the expected configuration.

  11. Retry the VM Power On operation.

Option 2:
Alternative UI Workarounds

  • Enable Fenced mode on the vApp and continue to use the same IP/MAC.

  • Power down the virtual machine using the conflicting IP/MAC address.

If the basic fixes above do not resolve the issue, please open a case with Broadcom Support for further assistance and note this Article ID (325491) in the problem description.

Additional Information

Refer Page 815 of Fence a vApp Network in the VMware Cloud Director Tenant Portal for detailed information on fenced networks.