MSP % Complete mismatch: Clarity shows 100% while MSP shows 99%
search cancel

MSP % Complete mismatch: Clarity shows 100% while MSP shows 99%

book

Article ID: 32475

calendar_today

Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

In Microsoft Project (MSP), Percent (%) Complete is incorrectly showing as 99% for one or more tasks, while in Clarity it is showing as 100%. Another symptom reported is that the % complete is being calculated based on on start/finish dates, but it's expected the % Complete should be able to be set manually. 

Environment

Release: All
Component: Clarity Microsoft Project Integration

Cause

This issue can happen if the MSP Option 'Updating Task status updates resource status' is checked. It is required to have this unchecked when integrating MSP with Clarity.

Resolution

Uncheck 'Updating Task status updates resource status'  using the below steps:

  1. Open the project in MSP
  2. Go to File, Options
  3. Select Schedule
  4. Scroll down to the Calculation options for this project section
  5. Ensure the setting under 'Updating Task status updates resource status' is unchecked. If not, uncheck it and click OK.

Notes:

  • This change will also need to be set for all projects going forward to prevent this issue:
    1. Under the Calculation options for this project, select 'All New Projects'
    2. Uncheck 'Updating Task status updates resource status'
    3. Click OK.
  • To review all required and recommended settings in MSP in working with Clarity to make sure these are set correctly, see Configure default settings in MSP to use with Clarity.

Additional Information