Console Unavailable with Fatal Errors or HTTP Error 500.19
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Console Unavailable with Fatal Errors or HTTP Error 500.19

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Article ID: 288999

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Updated On:

Products

Carbon Black App Control (formerly Cb Protection)

Issue/Introduction

  • The php_errors.log file includes:
    DB Error: [Microsoft][ODBC Driver 17 for SQL Server]SQL Server Network Interfaces: The logon attempt failed
  • In some instances, the Console is unavailable with error an error returned by IIS similar to:
    HTTP Error 500.19 – Internal Server Error 0x8007052e
  • Changes to the Service Account or IIS were recently made.

Environment

  • App Control Server: All Versions
  • Microsoft Windows Server: All Supported Versions

Cause

Potential causes can include

  • The IIS configuration was modified from default and the physical path credentials were configured
  • HTTP Error 500.19 – Internal Server Error 0x8007052e - caused by a lack of permissions on the physical path

Resolution

  1. Log in to the application server hosting the Console as the Carbon Black Service Account.
  2. Launch IIS Manager and navigate to: SERVERNAME > select Parity Console Web 
  3. From the right-hand menu > Actions > Basic Settings
    1. Click Connect as... and verify Application user (pass-through authentication) is chosen.
    2. Click Test Settings... and verify the Authentication Test passes and the Details include: The application pool identity is valid.
    3. If failures are encountered, review the Service Account Windows Permissions.
    4. Click OK to save any changes.
  4. Select the SERVERNAME > right-hand menu > Restart Server (or in an administrative command prompt execute: iisreset)

 

Additional Information