Troubleshooting Red Hat Channel and PM Import issues
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Troubleshooting Red Hat Channel and PM Import issues

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Article ID: 256664

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Updated On:

Products

Patch Management Solution

Issue/Introduction

You may see errors such as these:

Verifying RHN subscriptions
  Rhsm: Consumer Uuid 00000000-0000-0000-0000-000000000000 isn't valid for RHEL-I386-CLIENT-6
System.ArgumentOutOfRangeException: Index was out of range. Must be non-negative and less than the size of the collection.
Parameter name: index
   at System.ThrowHelper.ThrowArgumentOutOfRangeException(ExceptionArgument argument, ExceptionResource resource)
   at Altiris.PatchManagementLinux.Redhat.RhnSoftwareRepository.RegisterRhnSystems(Dictionary`2 supportedOs, Dictionary`2& enitlement)
   at Altiris.PatchManagementLinux.Redhat.RhnSoftwareRepository.ImportChannels()
Please check that valid RHN userName/password are specified.

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Failed to register RHN systems, please check that valid RHN userName/password are specified.
REST request failed. Response: StatusCode: 403, ReasonPhrase: 'Forbidden', Version: 1.1, Content: System.Net.Http.StreamContent, Headers:
{
x-candlepin-request-uuid: 21b03912-9367-42e1-88f7-282e8bc00366
X-Version: x.x.xx-x
X-Version: x.x.xx-x
Transfer-Encoding: chunked
Date: xxx, xx xxx xxxx xx:xx:xx xxx
Server: Apache-Coyote/1.1
Content-Type: application/json
}

Environment

Patch Management 8.x

Cause

Most problems are a result of an incorrect username and/or password in the Red Hat Patch Remediation Settings policy (Settings > Software > Patch Management > Red Hat Settings.)

Additionally, a common issue is that the user account in the Red Hat Patch Remediation Settings policy > Red Hat Network tab is not in the Organizational Administrators group in the Red Hat portal.

One issue that may affect all users happens when Red Hat has migrated you per "Transition of Red Hat's subscription services to console.redhat.com"

Another issue is due to the use of a new version of Candlepin (software subscription management tool).  This results in an inability to download the required certificates Red Hat uses in their subscription security and verification.

Resolution

  1. Verify the username and password used in Settings > Software > Patch Management > Red Hat Settings > Red Hat Network tab are correct, and that this user is an Organizational Admin in the Red Hat Portal. Note that setting up two-factor authentication for this account is not supported. (Create and manage other users)
  2. In some environments with an intermediate proxy server, the requests between ITMS and Red Hat may get corrupted. To help troubleshoot and confirm this issue, add the following value to the Notification Server: [HKEY_LOCAL_MACHINE\SOFTWARE\Altiris\Patch Management] "IgnoreCertificateCheck"=dword:00000001. After troubleshooting, delete IgnoreCertificateCheck.
  3. For the issue where Red Hat has migrated you per "Transition of Red Hat's subscription services to console.redhat.com", apply the latest point fix for 8.6 RU3 and 8.7.2 (note only those two versions have point fixes)
  4. For the issue due to the use of a new version of Candlepin (software subscription management tool), and if on 8.6 RU2 or RU3, apply the latest version of the point fixes for the installed version.

Additional Information

For issues where computers do not show applicable for expected errata, ensure Perl is installed on the endpoints: Red Hat Enterprise Linux Servers not populating under "Compliance by computer" and "Compliance by Erratum" for applicable Errata