UIM - UMP/Operator Console CABI proxy configuration
search cancel

UIM - UMP/Operator Console CABI proxy configuration

book

Article ID: 205475

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

We are trying to get the UIM 20.3. Operator Console working externally for access.

The UMP(or OC) is available outside of the company and you can log in to the Operator Console. However, the operator console CABI Dashboards do not load. (Spins forever)

We have a Proxy Server to allow the UMP (Or operator console) accessible externally. Do we need to configure a proxy also for CABI to be reachable? 

 

 

 

Environment

Release : 20.3.x

Component : UIM - OPERATOR CONSOLE

Cause

CABI needs to be reachable externally. When hitting the Operator Console, the browser will try to connect to the cabi_url defined in the wasp.cfg. If this is not reachable externally, then it is expected that no dashboard will be shown. 

Resolution

The Development Team confirmed that, by design, there should be an external URL to access CABI server content externally.

The cabi_url value should be updated with the external reachable url. Only then, the CABI content is displayed in OC/UMP.

So, In the cabi probe, define a setup/cabi_url key to contain the full name from the browser perspective (eg https://cabi.lan/cabijs).  

If you are using a Load Balancer, the cabi_url key defined will be the url that will be inserted into the pages so that the connection will be opened via the LB rather than directly to the CABI server. 

Note: The external url address must be accessible from within the internal CABI and OC servers. If this fails, the CABI probe will be unable to connect to the CABI url address and result in user sync / content upload failures. 

 

NOTE ABOUT OC 20.3.3 

If you are running UIM Operator Console 20.3.3 (instead of the base version UIM 20.3) the issue is similar but not identical. The "home page" in OC in 20.3.3 is no longer dependent and presented using CABI. Therefore this issue would not be visible on the OC home page but only on those pages that still depend on CABI to be presented. For example, you will see "Data Access" error when opening OC/Reports if the CABI_url defined in the cabi probe is not reachable from the Operator Console machine

Additional Information

 

 

 

Set Up Access to UMP Using a DMZ

https://techdocs.broadcom.com/us/en/ca-enterprise-software/it-operations-management/unified-infrastructure-management/20-1/installing/optional-post-installation-tasks/set-up-access-to-ump-using-a-dmz.html

 

Set Up Access to Operator Console (OC) Using a DMZ

https://techdocs.broadcom.com/us/en/ca-enterprise-software/it-operations-management/unified-infrastructure-management/20-3/installing/optional-post-installation-tasks/set-up-access-to-ump-using-a-dmz.html

 

If you reached this KB because you are not able to access the Operator Console content (spins forever) or if you have Data Access Error on operator console but not using proxy servers, check the following KB instead:

 

UIM Operator Console - Data Access Error
https://knowledge.broadcom.com/external/article?articleId=199555

UIM - Data access error Operator Console dashboards failed to load
https://knowledge.broadcom.com/external/article?articleId=187493

20.3.x-Operator Console Home page loads slowly, Group Trend Report redirects to CABI login screen, Data Access Error or Dashboard failed to load.
https://knowledge.broadcom.com/external/article/202982

UIM 20.3.2 - Operator Console Data Access Error in OC
https://knowledge.broadcom.com/external/article?articleId=206627