Errors in System Status page in NetOps portal for NFA datasources
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Errors in System Status page in NetOps portal for NFA datasources

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Article ID: 197109

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Updated On:

Products

CA Network Flow Analysis (NetQos / NFA) CA Performance Management - Usage and Administration

Issue/Introduction

On system status page the "Network Flow Analysis" section shows as "Failed" with the NFA data sources having status "Unreachable". 

NFA 10.0.4 (new install)



Also configuration changes in NetOps Portal to the Harvester/Application settings in the NFA data source configuration page on the Netops Portal result in a 500 error when saved

Environment

Component : NETWORK FLOW ANALYSIS NETOPS PORTAL

 

Cause


-TCP port 8981 [NFA data read via OData API] needs to be open between CA PC / CA NPC Console  and NFA console.

-Make sure "CA NFA Odata Service" is running on the NFA Console

-Confirm that the NFA console is configured with an IPV4 address and not IPV6 address.

NOTE: The ipv6 issue discussed below was resolved in NFA 10.0.5 / 20.2.5

 

 

Resolution

-TCP port 8981 [NFA data read via OData API] needs to be open between CA PC / CA NPC Console  and NFA console.

 

-Make sure "CA NFA Odata Service" is running on the NFA Console. Try restarting this service.

 

-Confirm that the NFA console is configured with an IPV4 address and not IPV6 address

See the steps below:

Message "Failed in sending REST: http://[0000:0000:0000:0000:0000:0000:0000:0001]:8981/odata/api/AuthToken java.net.ConnectException"

Can also verify by checking in NetOps portal if the NFA datasource is recorded with ipv6 address for OdataUrl

https://support.microsoft.com/en-us/help/929852/guidance-for-configuring-ipv6-in-windows-for-advanced-users

To add/modify the reg entry through UI,  can refer to the following screenshots:


If the environment doesn't have the registry entry called 'DisabledComponents', which is required and should have appropriate value can add the entry through the command line as mentioned in the article above or can use the regedit UI.

Please take backup of registry before any changes 

Change the name to 'DisabledComponents':
 

Edit the value as per the requirement (refer the article). (Hex 20 for 'Prefer IPv4 over IPv6. Hex FF for 'Disable IPv6')

Note: Please make sure that the NFA console machine is restarted after the registry change. 

2)

Port 8981 has to be open on the NFA console machine for communication to happen between NetOps Portal and NFA for NFA admin pages and SystemStatus.

NFA documentation has updated for OData API port:

https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/it-operations-management/network-flow-analysis/10-0-0/installing/system-recommendations-and-requirements/windows-servers/firewall-configuration.html

The NetOps documentation has been updated with the OData API port (8981) in the firewall configuration and also in requirements section: 

https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/it-operations-management/dx-netops/20-2/Performance-Monitoring-with-DX-Performance-Management/installing/review-installation-requirements-and-considerations.html

https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/it-operations-management/dx-netops/20-2/Flow-Monitoring-with-Network-Flow-Analysis/installing/system-recommendations-and-requirements/windows-servers/firewall-configuration.html

Additional Information

NFA Admin->System Status Page shows errors from Watchdog Service but configuration is correct

https://knowledge.broadcom.com/external/article/6052/nfa-adminsystem-status-page-shows-errors.html

KB: ConnectException invoking http://<nfa hostname>:8681/NFARS/ribsource/rib/soap?wsdl: Connection refused

https://knowledge.broadcom.com/external/article?articleId=127854

KB: ConsoleEventProducer: Failed to forward events to Event Manager because The remote name could not be resolved: 'hostname'

https://ca-broadcom.wolkenservicedesk.com/external/article?articleId=182946