ConnectException invoking http://<nfa hostname>:8681/NFARS/ribsource/rib/soap?wsdl: Connection refused
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ConnectException invoking http://<nfa hostname>:8681/NFARS/ribsource/rib/soap?wsdl: Connection refused

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Article ID: 127854

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Updated On:

Products

CA Network Flow Analysis (NetQos / NFA) DX NetOps

Issue/Introduction

Network Flow Analysis (NFA) Data Source (DS) integrated with DX NetOps Performance Management shows synchronization failures.

Sync failure for NFA DS in Portal.

I am not able to see any NFA data in NetOps Portal and the DMService logs shows the message below:

ERROR | RIB/Engine               | 2021-10-14 11:09:56,014 | com.ca.im.rib.engine.sources.SourceScanner                       
      | Failed to scan RIB source
java.util.concurrent.ExecMutionException: com.ca.im.rib.engine.sources.RIBSourceException: Unexpected error occurred while scanning a RIB source
  RIB Source URL: http://<NFA_HostName>:8681/NFARS/ribsource/rib/soap?wsdl
...
Caused by: com.ca.im.rib.engine.sources.RIBSourceException: Unexpected error occurred while scanning a RIB source
  RIB Source URL: http://<NFA_HostName>8681/NFARS/ribsource/rib/soap?wsdl
...
Caused by: javax.xml.ws.WebServiceException: Could not send Message.
...
Caused by: java.net.SocketTimeoutException: SocketTimeoutException invoking http://<NFA_HostName>:8681/NFARS/ribsource/rib/soap?wsdl: connect timed out
...
Caused by: java.net.SocketTimeoutException: connect timed out
 
The DMService.log is found in the (default path shown) /opt/CA/PerformanceCenter/DM/log directory.

Environment

All supported DX NetOps Performance Management releases

All supported DX NetOps Network Fault Management releases

Cause

Blocked 8681 port or NFA RibSource Service requires restart.

Resolution

  1. Attempt to load the URL in the error message while RDP'd directly into the NFA console. If it is working properly it should load an xml type output in the browser.
    • http://<nfa hostname>:8681/NFARS/ribsource/rib/soap?wsdl
      1. If we see do not see expected *.xml output:
        1. First verify port 8681 is open between NetOps Portal and the NFA Console on any external firewalls and local firewalls on each server. It must be open.
          1. Test using this command on the Portal host CLI targeting the NFA host
            1. nc -vz <NFA_Host> 8681
        2. Once the port is opened retest the URL. If it still fails to show the expected XML output:
          1. Check the NFA RibSource service on the NFA Console server to confirm it is running. If found not running start it. Retest the URL.
          2. If it is found running try restarting the service and retesting the URL.
  2. Once the URL loads properly perform a full resync of the NFA Data Source from Portal and attempt to view NFA data in Dashboards.
If none of this resolves the problem please download the latest RemoteEngineer tool from http://RemoteEngineer.ca.com and run the Diagnostics scan on the NFA Console Server and the Portal server and open an issue with Support. Please include the RemoteEngineer output.