Symantec Endpoint Encryption Help Desk Web Console Showing Blank Page, Generic Titles, HTTP Error or login images are missing
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Symantec Endpoint Encryption Help Desk Web Console Showing Blank Page, Generic Titles, HTTP Error or login images are missing

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Article ID: 174615

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Updated On:

Products

Endpoint Encryption Desktop Email Encryption Drive Encryption Encryption Management Server File Share Encryption Gateway Email Encryption PGP Command Line PGP Key Management Server PGP Key Mgmt Client Access and CLI API PGP SDK

Issue/Introduction

This article will go over scenarios if the Symantec Endpoint Encryption (SEE) Web Console shows a blank page, titles are not showing properly, some images are missing, or displays HTTP Error 404.7 - Not Found when trying to access the website using a web browser.

 

 

For information on the Dashboard and Web Console, see the following article, including the new OAuth functionality:

240649 - Symantec Endpoint Encryption Web Dashboard and Reports

240321 - OAuth Communications with Symantec Endpoint Encryption 11.4 and above

 

TIP: For general troubleshooting with SEE Communication and SEE Client Creation issues, see the following article: 
155127 - Symantec Endpoint Encryption Client communication and SEE Client Creation troubleshooting steps

 

Scenario 1: Blank Page

 

Scenario 2: Error Page

 

HTTP Error 404.7 - Not Found: The request filtering module is configured to deny the file extension.

Module: RequestFilteringModule

Notification: BeginRequest

Handler: ExtensionlessUrlHandler-Integrated-4.0

Physical Path: C:\Program Files (x86)\Symantec\Symantec Endpoint Encryption Management Server\CommunicationWS\WebConsole

 

Scenario 3: Images not loading properly on Login page or other pages

Scenario 4: Web Console Titles are showing as Generic instead of the true names

 

Cause

The Internet Information Services (IIS) Manager is set to disallow required file name extensions for the Symantec Endpoint Encryption Services website, or there are not sufficient privileges for the App Pool Identity, or Some of the Requirements were not installed.

Resolution

The following steps are specific to each method.

 

There are 3 solutions to this problem. The first 2 methods require the user perform the following steps:

  1. On the Symantec Endpoint Encryption Management Server (SEEMS), open the Internet Information Services (IIS) Manager
  2. In the "Connections" pane on the left, click the arrows to navigate to the following location Server Name > Sites > Symantec Endpoint Encryption Services > WebConsole
  3. Ensure WebConsole is highlighted in the left pane
  4. Double click on Request Filtering in the middle pane

 

Method 1: Allow unlisted File name extensions

  1. Click Edit Feature Settings... in the right pane
  2. Check Allow unlisted file name extensions
  3. Click OK


 

 



Method 2: Request Filtering for File Name Extensions

  1. Ensure you are on the Request Filtering screen and are on the File Name Extensions tab
  2. Right click in the white space within the File Name Extensions page



     
  3. Select Allow File Name Extensions...
  4. In the dialog box that appears, enter a single period




     
  5. Click OK
  6. Repeat steps 2-5, replacing the period with .asmx


     
  7. Repeat steps 2-5, replacing the period with .css
  8. Repeat steps 2-5, replacing the period with .html
  9. Repeat steps 2-5, replacing the period with .js
  10. Repeat steps 2-5, replacing the period with .json
  11. Repeat steps 2-5, replacing the period with .map
  12. Ensure the File Name Extensions tab includes all of the rules from the previous steps.


 

 

 

Method 3: Add Static Content to IIS

    Make sure Static Content , under Web Server (IIS) is installed on the Server Roles.

 

 

 

After completing one of the above methods above, refresh the WebConsole page on the web browser to see the functioning website.

240649 - Symantec Endpoint Encryption Web Dashboard and Reports
 

 

 

Method 4: Add .json and .svg to the appropriate SEE Management Server websites

In addition to the above, you may need to add ".json", which will handle the titles, and ".svg", which will handle the images:

Step 1 of 2: In IIS, click on the "Symantec Endpoint Encryption Services" webpage.  Then go to MIME Types and add the following entries:

Step 2 of 2: Next, go to the "WebConsole" website, and here add only the .svg entry as shown in the screenshot above. 

Note: It is not necessary to add the .json MIME type under "WebConsole".

Once these three entries have been added, the titles and the images should show up properly.

 

 

Method 5: Ensure proper permissions for the App Pool Identity

On occasion, under certain circumstances, the Application Pool Identity can be set to the "NetworkService" local accounts.
Using NetworkService may not have sufficient permissions to represent the Application Pool for SEE Management Server.
This can cause web pages to be blank, or not have the proper web asset labels, or even display "HTTP error 500" etc.

If you do have "NetworkService", it is recommended to use a different account that you know will at least have db_reader, db_writer, and public to he database.
Additionally, these accounts need to have proper access to the Active Directory objects for your domain. 

Step 1: In IIS, click on Application Pools section, and check the Identity column for the existing SymantecEndpointEncryption* application pools:

Step 2: Right-Click on the SymantecEndpointEncryptionAppPool and click Advanced Settings... and scroll in the resulting window to the Identity field.
Click the ellipses on the right of the field and update the user to a user that has these permissions mentioned above.

Note:
This account does not need to be a Domain or Enterprise admin, they just need to have the ability to read other Active Directory objects.
They also need db_reader, db_writer, and public database permissions.  

In this example, the account is called "appuser1":

Once set, repeat this process for the remaining SymantecEndpointEncryption* pools:

Method 6: Directory path for the web object settings

Although very rare, if you use an IIS Template that may force your websites to always use a specific directory, the SEE Management Server's web console may not operate properly.

To ensure the proper directory, open IIS and navigate down to the "Symantec Endpoint Encryption Services" website, and review the following three components:

*SEEIdentityServer
*SEEOAuthServer
*WebConsole

Click on each of these components and on the right side, click on "Basic Settings" and make sure the proper directory is being used for each entry:

C:\Program Files (x86)\Symantec\Symantec Endpoint Encryption Management Server\CommunicationWS\SEE IdentityServer

C:\Program Files (x86)\Symantec\Symantec Endpoint Encryption Management Server\CommunicationWS\SEEOAuthServer

C:\Program Files (x86)\Symantec\Symantec Endpoint Encryption Management Server\CommunicationWS\WebConsole

 

If you continue to have issues, please reach out to Symantec Encryption Support for further guidance. 

 



Additional Information