"Internal error occurs during Export of vSphere ESX Agent Manager" error when migrating vCenter Server 6.0 to 6.5
search cancel

"Internal error occurs during Export of vSphere ESX Agent Manager" error when migrating vCenter Server 6.0 to 6.5

book

Article ID: 315374

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

This article provides insight on how to recover from an ESX Agent Manager export failure during a Windows vCenter Server 6.0 migration to vCenter Server Appliance 6.5.

Symptoms:
  • Migrating a vCenter Server 6.0 installed on Windows to the vCenter Server Appliance 6.5 fails with this error:

    Internal error occurs during Export of vSphere ESX Agent Manager
After a vCenter Server 6.x upgrade failure on the source Windows vCenter Server there will be a file called VMware-VCS-logs-<year><month><day><hour><minute><second>.zip created on the desktop. The log entries below are found in this zip file. For more information see Triaging a vCenter Server 6.0 installation or upgrade failure (2105258).
  • In the UpgradeRunner.log file, you see entries similar to:

    <YYYY-MM-DD>T<HH:MM:SS>Z ERROR upgrade.states.component_states eam:Export: Remote script failed with an error [InternalError()]
    <YYYY-MM-DD>T<HH:MM:SS>Z ERROR upgrade.states.component_states eam:Export: failed with internal error. For details take a look at Export_com.vmware.eam_2016_11_16_09_42.log.
    <YYYY-MM-DD>T<HH:MM:SS>Z WARNING wf.wf_processor State Export com.vmware.eam has failed.
Notes:
  • The UpgradeRunner.log is found in the VMware-VCS-logs-<year><month><day><hour><minute><second>/vcsUpgrade folder.
  • The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.


Environment

VMware vCenter Server 6.5.x

Cause

There are multiple reasons that the EAM export would fail to export during the migration of vCenter Server 6.0 to VCSA 6.5:
  • Java Virtual Machine (JVM) heap exhaustion
  • EAM port misconfiguration

Resolution

To resolve this issue, select the article that matches your issue:
 

CAUSE RESOLUTION
Java Virtual Machine (JVM) heap exhaustion Export of vSphere ESX Agent Manager fails due to JVM heap exhaustion 
EAM port misconfiguration Export of vSphere ESX Agent Manager fails due to the EAM service using a custom port configuration



Additional Information