Export of vSphere ESX Agent Manager fails due to the EAM service using a custom port configuration
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Export of vSphere ESX Agent Manager fails due to the EAM service using a custom port configuration

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Article ID: 321368

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

Symptoms:
After experiencing the symptoms seen in KB Article "Internal error occurs during Export of vSphere ESX Agent Manager" error when migrating vCenter Server 6.0 to 6.5 (2147898), you see this additional symptom:

In the UpgradeRunner.log file, you see entries similar to: 

2016-11-16T20:33:32.342Z ERROR __main__ Cannot perform the upgrade, because of the following not allowed custom ports: HTTP Port (81, default 80)

Notes
  • The UpgradeRunner.log file is found in the VMware-VCS-logs-<year><month><day><hour><minute><second>/vcsUpgrade folder.
  • The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.


Environment

VMware vCenter Server 6.5.x
VMware vCenter Server Appliance 6.5.x

Cause

This issue occurs because the EAM service is using a custom port. From the error seen in the symptoms section, the default port of 80 has been changed to 81.

Resolution

To resolve this issue, change the EAM port back to the default port (80) in the eam.properties file.

Note: The default location for the eam.properties file is C:\Program Files\VMware\Infrastructure\tomcat\webapps\eam\WEB-INF.