Console Inaccessible with Demo Expired Message after Server Upgrade to 8.11 or Higher
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Console Inaccessible with Demo Expired Message after Server Upgrade to 8.11 or Higher

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Article ID: 388701

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Updated On:

Products

Carbon Black App Control

Issue/Introduction

After upgrading to Server version 8.11.x+ the Web Console displays an error message similar to:

Your Demo of Carbon Black App Control has expired. Contact Global Customer Assistance to purchase a copy.

Environment

  • App Control Server: 8.11.x or Higher

Cause

  • The Server License file was already expired before the upgrade to Server 8.11.0
  • There is an DNS issue resolving the Web Server Address to the correct IP address
  • There is an IIS error or misconfiguration

Resolution

A valid Server License is required to resolve the Demo Expired message.

  1. Log in to the Broadcom Support Portal and download your current Server License.
  2. Follow these steps to import the non-expired Server License:
    1. Stop the App Control Server and App Control Reporter services.
    2. Run SQL Server Management Studio as the Carbon Black Service Account.
    3. Open the .lic file in a text editor and copy the content
    4. Update the following SQL query by pasting the license value within the single quotes:
      USE das; EXECUTE dbo.UpdateLicense 'USE VALUE FROM LIC', '0'
    5. Start the Server and Reporter services then attempt to access the Console again
  3. If the current license is not available for download in the Support portal:

If getting this error with a valid license, check the following:

I. DNS resolution - the web Console validates the license by making an API call to the web server address stored in the database.

  1. Verify the correct Web Server Address is in the database and that it resolves to the IP address of the server for both IPv4 and IPv6
    1. Run SQL Server Management Studio as the Carbon Black Service Account
    2. Execute the following query to get the Web Server Address from the App Control database:
      USE das; SELECT value FROM shepherd_configs (NOLOCK) WHERE name = 'WebServerAddress'
    3. Verify the Web Server Address matches the expected App Control Server name
      • If the name does not match, update it with this query by adjusting the value within single quotes accordingly
        USE das; EXEC dbo.updateshepherdconfig @name = 'WebServerAddress', @value = 'YourAppCServer.example.com';
  2. Add entries in the HOSTS file for the Web Server Address to resolve to the Local IPs of the server
    1. Run Notepad as Administrator > File > Open > C:\Windows\System32\drivers\etc\hosts
    2. Add the following lines at the bottom:
      127.0.0.1  YourAppCServer.example.com
      ::1        YourAppCServer.example.com
      • If the HOSTS file cannot be modified, make sure that the DNS resolves the Web Server Address name to the external IP address of the AppC server for both IPv4 and IPv6 
  3. Validate the settings by pinging the Web Server Address:
    ping -4 YourAppCServer.example.com
    ping -6 YourAppCServer.example.com

II. Errors or misconfiguration of IIS Web Server - check the PHP Errors log for errors such as:

  1. Open the \Bit9\Parity Console\WebUI\Logs\php_errors.log in a text editor.
  2. Search for login.php and review any API Errors, examples:
    • HTTP Code 401 (Unauthorized) is typically caused by disabling Anonymous Authentication in IIS Manager; to resolve it re-enable the config
      API Error from page /login.php: GET appc.example.com/api/bit9platform/restricted/licenseUsage/ with params [] 
      .....
      returned http code 401 and result in 0.0067501068115234 seconds
    • HTTP Code 0 is typically caused by an IIS configuration error; to resolve it, reinstall IIS
      API Error from page /login.php: GET appc.example.com/api/bit9platform/restricted/licenseUsage/ with params [] 
      .....
      http code 0 and result  in 0.37768602371216 seconds
      Last Curl error: Empty reply from server
    • HTTP Code 500 has many potential culprits, but could mean a potential permission error (also check IIS Identity) or missing dependency requiring an IIS reinstall, example:
      API Error from page /login.php: GET appc.example.com/api/bit9platform/restricted/licenseUsage/ with params [] 
      .....
      http code 500 and result in 0.13003587722778 seconds

Additional Information

  • If any issues are encountered while downloading or locating the Server License:
  • If getting this error with a valid license, confirm that the IIS setting Anonymous Authentication is enabled