NSX installation on ESXi is stuck at 0%
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NSX installation on ESXi is stuck at 0%

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Article ID: 373055

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Updated On: 02-27-2025

Products

VMware NSX

Issue/Introduction

You install NSX on an ESXi but the installation is stuck at 0%

In /var/log/proton/nsxapi.log you can see an exception as "UnknownHostException" on each Manager node.

<Timestamp>  INFO providerTaskExecutor-1-40 VCExecuteOperationImpl 96151 FABRIC [nsx@6876 comp="nsx-manager" level="INFO" subcomp="manager"] Request compute-manager for creating ESX user nsxuser on host host-****.
<Timestamp>  INFO providerTaskExecutor-1-40 VCSoapServiceImpl 96151 FABRIC [nsx@6876 comp="nsx-manager" level="INFO" subcomp="manager"] Calling CM: <CM UUID> for creating ESX user
<Timestamp>  INFO providerTaskExecutor-1-40 VCSoapServiceImpl 96151 FABRIC [nsx@6876 comp="nsx-manager" level="INFO" subcomp="manager"] Create user nsxuser on host host-**** with cmId <CM UUID>
<Timestamp>  WARN providerTaskExecutor-1-40 VcUtils 96151 SYSTEM [nsx@6876 comp="nsx-manager" level="WARNING" subcomp="manager"] Unable to find ip addresses for <vCenter FQDN>
java.net.UnknownHostException: <vCenter FQDN>: Name or service not known
        at java.net.Inet4AddressImpl.lookupAllHostAddr(Native Method) ~[?:1.8.0_382]
        at java.net.InetAddress$2.lookupAllHostAddr(InetAddress.java:867) ~[?:1.8.0_382]
        at java.net.InetAddress.getAddressesFromNameService(InetAddress.java:1302) ~[?:1.8.0_382]
        at java.net.InetAddress$NameServiceAddresses.get(InetAddress.java:815) ~[?:1.8.0_382]

Environment

VMware NSX

Cause

Please note that installation process might run on any Manager node regardless of VIP owner or which node you use to install NSX.
If at lease one Manager node, but not all NSX Manager nodes, has trouble in resolving the vCenter FQDN, it is possible that you can initiate installing NSX but the installation is stuck at 0%

Resolution

  • Make sure all the Manager nodes can resolve vCenter FQDN.
  • You can use nslookup command on NSX Manager to check name resolution.
  • If NSX Manager fails to resolve vCenter FQDN, configure correct DNS servers or fix your DNS servers.

Additional Information

If this KB has not resolved the issue, please review the additional troubleshooting steps which can be found in Troubleshooting NSX Installation Operations

If you are contacting Broadcom support about this issue, please provide the following:

  • Record all steps necessary to recreate the error
  • Record all text of any error messages
  • Include timestamps of when the error was experienced
  • Retrieve log bundles from all NSX components involved (NSX Managers and ESXi hosts/Edges)

Handling Log Bundles for offline review with Broadcom support