How to remove a failed disk from a vSAN disk group/host
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How to remove a failed disk from a vSAN disk group/host

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Article ID: 327038

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Updated On:

Products

VMware vSAN

Issue/Introduction

  • Disk groups need to be resized to meet the company's needs
  • The capacity disk is not visible at the time of creating the disk group.
  • Removing a disk can cause a PSOD or render the host unresponsive if not done properly.
  • The disk or disk group must be removed via the vCenter Web Client before removing the physical disk from the host; otherwise, the removal process will fail.
  • The disk may return after a reboot and resume normal operation

Environment

VMware vSAN OSA (All Versions)

Cause

vSAN disk reports as failed

Resolution

  1. Confirm if Deduplication and Compression is in use or not via Cluster > Configure > vSAN > Services > Space Efficiency 
  2. Place the host into maintenance mode with Ensure Accessibility

  3. If dedup is not in use, then go to vSAN Cluster > Configure > Disk Management > Select the disk to be removed > Confirm no data impact with the Pre-Check Data Migration > If no data impact, then select Remove Disk(s)

  4. If deduplication is enabled or if it's a cache tier disk, the entire disk group must be removed and recreated. vSAN Cluster > Configure > Disk Management > Select the disk group to be removed > Confirm no data impact with the Pre-Check Data Migration > If no data impact then select Remove Disk Group

  5. From the ESXi command line, follow KB How to manually remove and recreate a vSAN disk group using esxcli

    If the physical disk was removed from the host before removing the disk/disk group via vCenter Web Client, follow the above KB to remove the disk/disk group via the ESXi CLI.

    If the disk or disk group cannot be removed for any reason, open a case with vSAN support for further assistance.

Additional Information