Removing a failed or absent disk from a vSAN disk group/host
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Removing a failed or absent disk from a vSAN disk group/host

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Article ID: 327038

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Updated On:

Products

VMware vSAN

Issue/Introduction

This article provides steps to remove a failed, absent, or unhealthy disk from a vSAN OSA disk group. Symptoms may include a "vSAN disk group is unhealthy" alert in the vSphere Client, disks appearing as "Absent" in Disk Management, or errors in vmkernel.log such as ScsiDeviceIO: READ CAPACITY on device failed..

  • Disk groups need to be resized to meet the company's needs
  • The capacity disk is not visible at the time of creating the disk group.
  • Removing a disk can cause a PSOD or render the host unresponsive if not done properly.
  • The disk or disk group must be removed via the vSphere Client before removing the physical disk from the host; otherwise, the removal process will fail.
  • The disk may return after a reboot and resume normal operation

Environment

VMware vSAN OSA (All Versions)

Cause

A physical disk failure, hardware error, or permanent loss of connectivity leads to the disk being marked as "Absent" or "Unhealthy" within the vSAN cluster.

Resolution

  1. If the disk is marked as Absent, verify if the physical hardware has been replaced or if the disk is permanently inaccessible.
  2. Confirm if Deduplication and Compression is in use or not via vSAN Cluster > [Configure] > vSAN / [Services] > Space Efficiency 

  3. Place the host into maintenance mode with Ensure Accessibility

  4. If dedup is not in use, then go to vSAN Cluster > [Configure] > vSAN / [Disk Management] > select the target host and [VIEW DISKS] > select the disk to be removed >  [GO TO PRE-CHECK] and perform a [PRE-CHECK] to verify there is no data impact > If no data impact, then select [REMOVE] disk

  5. If deduplication is enabled or if it's a cache tier disk, the entire disk group must be removed and recreated. vSAN Cluster > [Configure] > vSAN / [Disk Management] > select the target host and [VIEW DISKS] >  select the disk group to be removed > [GO TO PRE-CHECK] and perform a [PRE-CHECK] to verify there is no data impact > If no data impact then select [REMOVE] disk group

  6. From the ESXi command line, follow KB Managing and Configuring a vSAN disk group using esxcli commands

    If the physical disk was removed from the host before removing the disk/disk group via vSphere Client, follow the above KB to remove the disk/disk group via the ESXi CLI.

    If the disk or disk group cannot be removed for any reason, open a case with vSAN support for further assistance.

Additional Information