vSANディスクグループ/ホストから障害が発生したディスクを削除する
search cancel

vSANディスクグループ/ホストから障害が発生したディスクを削除する

book

Article ID: 440150

calendar_today

Updated On:

Products

VMware vSAN

Issue/Introduction

免責事項:これは英文の記事「Removing a failed disk from a vSAN disk group/host」の日本語訳です。
記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。

  • 企業の要件に合わせてディスクグループのサイズを変更する必要があります。
  • ディスクグループ作成時にキャパシティディスクが表示されません。
  • 適切な手順で実施しない場合、ディスクの削除によりPSODが発生したり、ホストが応答不能に陥る可能性があります。
  • 物理ディスクをホストから取り外す前に、vSphere Client 経由でディスクまたはディスクグループを削除する必要があります。そうしないと、削除プロセスが失敗します。
  • ホストの再起動後にディスクが復帰し、正常な動作を再開する場合があります。

Environment

VMware vSAN OSA (全バージョン)

Cause

vSAN ディスクが障害として報告されています。

Resolution

  1. 重複排除と圧縮が有効になっているかどうかは、vSAN クラスタ > [構成] > vSAN / [サービス] > 容量効率で確認します。 
  2. アクセシビリティの確保(Ensure Accessibility)を選択して、ホストをメンテナンスモードに切り替えます。
  3. 重複排除が使用されていない場合は、vSAN クラスタ > [構成] > vSAN / [ディスク管理] > 対象ホストを選択し [ディスクの表示] > 削除するディスクを選択 > [事前チェックに移動]で[事前チェック]を行いデータへの影響がないことを検証 > データへの影響がない場合は、ディスクの[削除]を選択します。
  4. 重複排除が有効になっている場合、またはキャッシュ層ディスクの場合は、ディスクグループ全体を削除して再作成する必要があります。vSAN クラスタ > [構成] > vSAN / [ディスク管理] > 対象ホストを選択し [ディスクの表示]  > 削除するディスクグループを選択 > [事前チェックに移動]で[事前チェック]を行いデータへの影響がないことを検証 > データへの影響がない場合は、ディスクグループの[削除]を選択します。
  5. ESXi コマンドラインからは、Managing and Configuring a vSAN disk group using esxcli commands の記事の手順に沿って操作を実施します。

vSphere Client 経由でディスク/ディスクグループを削除する前に、物理ディスクをホストから取り外してしまった場合は、上記の 記事 に従って ESXi CLI からディスク/ディスクグループを削除します。

何らかの理由でディスクまたはディスクグループを削除できない場合は、vSAN サポートにケースをオープンして追加の支援を要請してください。

Additional Information