vCenter network connectivity lost - Recover vCenter network when connected to a Distributed Switch
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Article ID: 318719
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Updated On:
Products
VMware vCenter Server
Issue/Introduction
This guide will help you build a temporary Standard Switch where you will connect vCenter to recover from the network down scenario. Then you can make the necessary changes in the DVS to return to a good state.
Most of the steps are only possible via command line.
Symptoms:
Management Network only exists in a Distributed Switch
There are no Ephemeral Ports in the cluster
vCenter Server lost network connectivity after an unplanned or planned outage.
You cannot connect vCenter back to a Distributed Switch portgroup in the same or different hosts
You are unable to open the vCenter vSphere Client to make any changes to the network because vCenter network connection is down
This error appears when trying to modify network settings on any ESXi host. Also, it can show up if you want to change network adapters for a ESXi host connected to a DVS with non-ephemeral ports:
Addition or reconfiguration of network adapters attached to non-ephemeral distributed virtual port groups is not supported.
Environment
VMware vCenter Server 6.x VMware vCenter Server 8.0.x VMware vCenter Server 7.0.x
Cause
If vCenter is connected to a Distributed Switch and it loses network access, vCenter is not able to connect to a Distributed Port because it does not have access to the ESXis.
***Please note if you have LACP configured on your physical switch you will need to temporarily break the LACP configuration so you can remove a NIC from the vDS to be available for the vCenter to use on the standard switch (unless you have non-LACP NICs available and configured to pass the traffic). If you do not break the LACP configuration before moving the NIC off the vDS this can cause further issues to your environments connectivity***
***Please also ensure before proceeding you have access to the DCUI/iLO/iDRAC for the host you'll be performing the below steps***
Resolution
Follow this Step-by-Step guide:
Remove a vmnic located in the DVS connected to the Management Network
Identify the Port ID where the vmnic that you want to remove is connected to the DVS
First, we will connect vCenter’s virtual machine to the new Standard Switch Portgroup. This will help to regain network access to vCenter. This will also allow the ESXIs to connect back to vCenter Server too and you will be able to manage your infrastructure again.
Login to the ESXi vSphere Client with administrator credentials
Go to “Virtual Machines”
Check vCenter’s Virtual Machine
Click in “Actions” > “Edit Settings”
Connect Network Adapter 1 to the newly created Standard Switch Portgroup
Click Save
Note: Up until now you should have recovered vCenter’s network connectivity and now you should be able to connect to its vSphere Client. If you still can’t, make sure the Standard Switch Portgroup has the correct VLAN and MTU configuration
Once you have reviewed that you can see everything is ok in your vCenter Inventory, let’s now migrate vCenter back to the DVS so that we can have the same configuration before the outage.
If you are not logged in the vCenter vSphere Client already, login to vCenter with Administrator credentials.
Go to the vCenter’s virtual machine, right click it and select “Edit Settings”.
Connect Network Adapter 1 to the Management Distributed Switch Portgroup
Click OK
Make sure you do not lose network access again. If everything is ok after a couple of minutes, continue to the next steps.
Migrate vmnic back to the DVS.
Let’s put the vmnic back to the DVS by following these steps:
If you are not logged in the vCenter vSphere Client already, login to vCenter with Administrator credentials.
Go to the vCenter’s virtual machine, right click it and select “Edit Settings”.
Connect Network Adapter 1 to the Management Distributed Switch Portgroup
Click OK
Make sure you do not lose network access again. If everything is ok after a couple of minutes, continue to the next steps.
Migrate the vmnic and vmk back to the DVS
Let’s put the vmnic back to the DVS by following these steps:
If you are not logged in the vCenter vSphere Client already, login to vCenter with Administrator credentials.
Go to the “Networking” tab.
Right click the DVS and select “Add and Manage Hosts”
Select “Manage host networking” and click Next
Click “Attached hosts…”
Check the ESXi with the vmk and vmnic that you want to add back to the DVS and click OK
Click Next
On the "Manage physical adapters" list, select the vmnic and click “Assign uplink”
Select an Uplink with empty “Assigned Adapter” and click OK
Click Next
Click Next in "Manage VMkernel adapters"
Click Next in "Migrate VM networking"
Click Finish
Delete the Standard Switch.
You are now able to delete the temporary Standard Switch we created to recover vCenter’s network connectivity.
If you are not logged in the vCenter vSphere Client already, login to vCenter with Administrator credentials.
Go to the “Hosts and Clusters” Tab
Select the ESXi used during this process
Click in the “Configure” tab
Click on “Virtual Switches” under “Networking”
Look for the temporary Standard Switch you created and click the ellipsis “…”
Click “Remove”
Click “Yes” in the warning that pops up
You have now successfully recovered vCenter’s network connectivity and the environment should be up and running.
Impact/Risks: There should be at least 2 vmnics used for the Management Network because in one of the steps we will remove one vmnic from the DVS Management Portgroup so that we can use it for the Standard Switch that we will create temporarily.
If you do not have 2 vmnics in the ESXi, it is recommended that you follow these steps via DCUI Shell. Otherwise, you will lose access to SSH when you run the remove vmnic command and won’t be able to continue with the process.