vRLI 8.14.x credentials are disconnected in SDDC Manager password management
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vRLI 8.14.x credentials are disconnected in SDDC Manager password management

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Article ID: 316054

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Updated On:

Products

VMware Cloud Foundation

Issue/Introduction

This KB is designed to help with clearing the disconnected state of the vRLI products in SDDC


Symptoms:
  • The admin and root credentials for vRLI are in a disconnected state in the SDDC UI
  • Attempts to remediate the accounts fail with "Unable to ssh to vrli nodes for <vRLI_FQDN>" error
  • An inventory sync from vRSLCM for vRLI product clears the disconnected states but the accounts become disconnected again overnight.
  • SSH from the SDDC to the vRLI nodes succeeds
  • Passwords stored in the SDDC for the vRLI products are correct and not expired.


Environment

VMware Cloud Foundation 4.5.2

Cause

SDDC Manager requires the ecdsa-sha2-nistp256 keys from all vRLI nodes and these are not normally stored in the known_hosts files on the SDDC Manager. 

Resolution

- Take a snapshot of the SDDC Manager

- Use the fix_known_hosts.sh script from KB: How to update the SSH host keys on the SDDC Manager
for every Aria node that's disconnected.

- Once complete, restart the services on the SDDC Manager:
# /opt/vmware/vcf/operationsmanager/scripts/cli/sddcmanager_restart_services.sh

- Remediate the disconnected accounts and wait 24 hours to ensure they do not enter a disconnected state again.

 

If this does not resolve, please open a ticket with Broadcom Support for further assistance.