Unprotected Agents With Red Status (macOS)
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Article ID: 286642
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Updated On: 07-09-2024
Products
Carbon Black App Control (formerly Cb Protection)
Environment
- App Control Agent: All Supported Versions
- macOS: All Supported Versions
Cause
App Control driver is either not properly installed or not fully loaded.
Resolution
- Verify any third party security application has all Agent Exclusions added.
- Verify the Agent and macOS combination being used is supported.
- Use the following command in Terminal to verify the System Extension for Team ID 7AGZNQ2S2T is Enabled & Active:
systemextensionsctl list
Example Output:
teamID name [state]
7AGZNQ2S2T appc-es-extension [activated enabled]
- Check for errors when manually starting the System Extension via Terminal:
cd /Applications/Bit9/Agent
./appc-es-loader.app/Contents/MacOS/appc-es-loader
- In System Preferences > Security & Privacy > Privacy > Full Disk Access: Verify permissions have been granted to:
- appc_es_extension
- b9notifier
- b9daemon
- Reboot the endpoint, or restart the Agent:
cd /Applications/Bit9/Tools
./b9cli --password 'GlobalCLIPassword'
./b9cli --shutdown
sudo launchctl unload /Library/LaunchDaemons/com.bit9.Daemon.plist
sudo launchctl load /Library/LaunchDaemons/com.bit9.Daemon.plist
./b9cli --status
- Upgrade to the latest version of the Agent
- A full uninstall of the Agent and manual reinstall may be required.
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